[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <CAKwvOdnhPCDRFMhYiAr2kSCDWrL_gaY8c6XHJ96PupcN-wcDpQ@mail.gmail.com>
Date: Tue, 19 Jun 2018 10:08:55 -0700
From: Nick Desaulniers <ndesaulniers@...gle.com>
To: pbonzini@...hat.com
Cc: joe@...ches.com, Matthias Kaehlcke <mka@...omium.org>,
rkrcmar@...hat.com, Thomas Gleixner <tglx@...utronix.de>,
hpa@...or.com, x86@...nel.org, kvm@...r.kernel.org,
LKML <linux-kernel@...r.kernel.org>
Subject: Re: [PATCH] kvm: x86: mmu: Add cast to negated bitmasks in update_permission_bitmask()
On Tue, Jun 19, 2018 at 8:19 AM Paolo Bonzini <pbonzini@...hat.com> wrote:
>
> On 15/06/2018 20:45, Nick Desaulniers wrote:
> >>
> >>> In any case I think it it preferable to fix the code over disabling
> >>> the warning, unless the warning is bogus or there are just too many
> >>> occurrences.
> >> Maybe.
> > Spurious warning today, actual bug tomorrow? I prefer to not to
> > disable warnings wholesale. They don't need to find actual bugs to be
> > useful. Flagging code that can be further specified does not hurt.
> > Part of the effort to compile the kernel with different compilers is
> > to add warning coverage, not remove it. That said, there may be
> > warnings that are never useful (or at least due to some invariant that
> > only affects the kernel). I cant think of any off the top of my head,
> > but I'm also not sure this is one.
>
> This one really makes the code uglier though, so I'm not really inclined
> to applying the patch.
Note that of the three variables (w, u, x), only u is used later on.
What about declaring them as negated with the cast, that way there's
no cast in a ternary?
Ex:
diff --git a/arch/x86/kvm/mmu.c b/arch/x86/kvm/mmu.c
index d594690d8b95..53673ad4b295 100644
--- a/arch/x86/kvm/mmu.c
+++ b/arch/x86/kvm/mmu.c
@@ -4261,8 +4261,9 @@ static void update_permission_bitmask(struct
kvm_vcpu *vcpu,
{
unsigned byte;
- const u8 x = BYTE_MASK(ACC_EXEC_MASK);
- const u8 w = BYTE_MASK(ACC_WRITE_MASK);
+ const u8 x_not = (u8)~BYTE_MASK(ACC_EXEC_MASK);
+ const u8 w_not = (u8)~BYTE_MASK(ACC_WRITE_MASK);
+ const u8 u_not = (u8)~BYTE_MASK(ACC_USER_MASK);
const u8 u = BYTE_MASK(ACC_USER_MASK);
bool cr4_smep = kvm_read_cr4_bits(vcpu, X86_CR4_SMEP) != 0;
@@ -4278,11 +4279,11 @@ static void update_permission_bitmask(struct
kvm_vcpu *vcpu,
*/
/* Faults from writes to non-writable pages */
- u8 wf = (pfec & PFERR_WRITE_MASK) ? ~w : 0;
+ u8 wf = (pfec & PFERR_WRITE_MASK) ? w_not : 0;
/* Faults from user mode accesses to supervisor pages */
- u8 uf = (pfec & PFERR_USER_MASK) ? ~u : 0;
+ u8 uf = (pfec & PFERR_USER_MASK) ? u_not : 0;
/* Faults from fetches of non-executable pages*/
- u8 ff = (pfec & PFERR_FETCH_MASK) ? ~x : 0;
+ u8 ff = (pfec & PFERR_FETCH_MASK) ? x_not : 0;
/* Faults from kernel mode fetches of user pages */
u8 smepf = 0;
/* Faults from kernel mode accesses of user pages */
Maybe you have a better naming scheme than *_not ? What do you think?
--
Thanks,
~Nick Desaulniers
Powered by blists - more mailing lists