[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <20180713023750.GA30532@vmware.com>
Date: Thu, 12 Jul 2018 19:37:50 -0700
From: Sinclair Yeh <syeh@...are.com>
To: "Gustavo A. R. Silva" <gustavo@...eddedor.com>
Cc: Christian Koenig <christian.koenig@....com>,
Roger He <Hongbo.He@....com>, David Airlie <airlied@...ux.ie>,
linux-kernel@...r.kernel.org, dri-devel@...ts.freedesktop.org
Subject: Re: [PATCH] drm/ttm: use swap macro in ttm_bo_handle_move_mem
On Mon, Jul 09, 2018 at 10:24:47AM -0500, Gustavo A. R. Silva wrote:
> Make use of the swap macro and remove unnecessary variable *tmp_mem*.
> This makes the code easier to read and maintain. Also, reduces the
> stack usage.
>
> This code was detected with the help of Coccinelle.
>
> Signed-off-by: Gustavo A. R. Silva <gustavo@...eddedor.com>
> ---
> drivers/gpu/drm/ttm/ttm_bo.c | 7 ++-----
> 1 file changed, 2 insertions(+), 5 deletions(-)
>
> diff --git a/drivers/gpu/drm/ttm/ttm_bo.c b/drivers/gpu/drm/ttm/ttm_bo.c
> index 5d8688e52..5142dcb 100644
> --- a/drivers/gpu/drm/ttm/ttm_bo.c
> +++ b/drivers/gpu/drm/ttm/ttm_bo.c
> @@ -287,12 +287,9 @@ static int ttm_bo_handle_move_mem(struct ttm_buffer_object *bo,
>
> if (ret) {
> if (bdev->driver->move_notify) {
> - struct ttm_mem_reg tmp_mem = *mem;
> - *mem = bo->mem;
> - bo->mem = tmp_mem;
> + swap(*mem, bo->mem);
> bdev->driver->move_notify(bo, false, mem);
> - bo->mem = *mem;
> - *mem = tmp_mem;
> + swap(*mem, bo->mem);
This code assumes bo->mem is the same as tmp_mem after the call to
move_notify. Is this always true?
> }
>
> goto out_err;
> --
> 2.7.4
>
> _______________________________________________
> dri-devel mailing list
> dri-devel@...ts.freedesktop.org
> https://na01.safelinks.protection.outlook.com/?url=https%3A%2F%2Flists.freedesktop.org%2Fmailman%2Flistinfo%2Fdri-devel&data=02%7C01%7Csyeh%40vmware.com%7C3bd79878de5141b5187408d5e6326e6d%7Cb39138ca3cee4b4aa4d6cd83d9dd62f0%7C1%7C0%7C636668026634710967&sdata=2raJ6TBpcEM5W7hi8iCEnrEdcfJa3W5ct3tF%2BlSZLkQ%3D&reserved=0
Powered by blists - more mailing lists