[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <20180716135335.hnvj5kqvsrrwzp3b@mwanda>
Date: Mon, 16 Jul 2018 16:53:36 +0300
From: Dan Carpenter <dan.carpenter@...cle.com>
To: Todd Poynor <toddpoynor@...il.com>
Cc: Rob Springer <rspringer@...gle.com>,
John Joseph <jnjoseph@...gle.com>,
Ben Chan <benchan@...omium.org>,
Greg Kroah-Hartman <gregkh@...uxfoundation.org>,
devel@...verdev.osuosl.org, Zhongze Hu <frankhu@...omium.org>,
linux-kernel@...r.kernel.org, Simon Que <sque@...omium.org>,
Guenter Roeck <groeck@...omium.org>,
Todd Poynor <toddpoynor@...gle.com>,
Dmitry Torokhov <dtor@...omium.org>
Subject: Re: [PATCH 04/18] staging: gasket: device registration error and
unregister fixups
On Fri, Jul 13, 2018 at 10:58:02PM -0700, Todd Poynor wrote:
> @@ -376,7 +377,10 @@ int gasket_register_device(const struct gasket_driver_desc *driver_desc)
> fail1:
> class_destroy(internal->class);
>
> +fail0:
GW-BASIC sytle label names are an anti-pattern. It's better to name the
labels after what they do, just like function names describes what the
function does. Here it would be "goto clear_desc;" or something. It
doesn't have to be perfect but so long as you *try* to name it something
useful that's better than not trying.
> + mutex_lock(&g_mutex);
> g_descs[desc_idx].driver_desc = NULL;
> + mutex_unlock(&g_mutex);
> return ret;
> }
regards,
dan carpenter
Powered by blists - more mailing lists