[<prev] [next>] [thread-next>] [day] [month] [year] [list]
Message-Id: <20180718024944.577-1-bhe@redhat.com>
Date: Wed, 18 Jul 2018 10:49:40 +0800
From: Baoquan He <bhe@...hat.com>
To: linux-kernel@...r.kernel.org, akpm@...ux-foundation.org,
robh+dt@...nel.org, dan.j.williams@...el.com,
nicolas.pitre@...aro.org, josh@...htriplett.org,
fengguang.wu@...el.com, bp@...e.de, andy.shevchenko@...il.com
Cc: patrik.r.jakobsson@...il.com, airlied@...ux.ie, kys@...rosoft.com,
haiyangz@...rosoft.com, sthemmin@...rosoft.com,
dmitry.torokhov@...il.com, frowand.list@...il.com,
keith.busch@...el.com, jonathan.derrick@...el.com,
lorenzo.pieralisi@....com, bhelgaas@...gle.com, tglx@...utronix.de,
brijesh.singh@....com, jglisse@...hat.com, thomas.lendacky@....com,
gregkh@...uxfoundation.org, baiyaowei@...s.chinamobile.com,
richard.weiyang@...il.com, devel@...uxdriverproject.org,
linux-input@...r.kernel.org, linux-nvdimm@...ts.01.org,
devicetree@...r.kernel.org, linux-pci@...r.kernel.org,
ebiederm@...ssion.com, vgoyal@...hat.com, dyoung@...hat.com,
yinghai@...nel.org, monstr@...str.eu, davem@...emloft.net,
chris@...kel.net, jcmvbkbc@...il.com, gustavo@...ovan.org,
maarten.lankhorst@...ux.intel.com, seanpaul@...omium.org,
linux-parisc@...r.kernel.org, linuxppc-dev@...ts.ozlabs.org,
Baoquan He <bhe@...hat.com>
Subject: [PATCH v7 0/4] resource: Use list_head to link sibling resource
This patchset is doing:
1) Move reparent_resources() to kernel/resource.c to clean up duplicated
code in arch/microblaze/pci/pci-common.c and
arch/powerpc/kernel/pci-common.c .
2) Replace struct resource's sibling list from singly linked list to
list_head. Clearing out those pointer operation within singly linked
list for better code readability.
2) Based on list_head replacement, add a new function
walk_system_ram_res_rev() which can does reversed iteration on
iomem_resource's siblings.
3) Change kexec_file loading to search system RAM top down for kernel
loadin, using walk_system_ram_res_rev().
Note:
This patchset only passed testing on x86_64 arch with network
enabling. The thing we need pay attetion to is that a root resource's
child member need be initialized specifically with LIST_HEAD_INIT() if
statically defined or INIT_LIST_HEAD() for dynamically definition. Here
Just like we do for iomem_resource/ioport_resource, or the change in
get_pci_domain_busn_res().
v6:
http://lkml.kernel.org/r/20180704041038.8190-1-bhe@redhat.com
v5:
http://lkml.kernel.org/r/20180612032831.29747-1-bhe@redhat.com
v4:
http://lkml.kernel.org/r/20180507063224.24229-1-bhe@redhat.com
v3:
http://lkml.kernel.org/r/20180419001848.3041-1-bhe@redhat.com
v2:
http://lkml.kernel.org/r/20180408024724.16812-1-bhe@redhat.com
v1:
http://lkml.kernel.org/r/20180322033722.9279-1-bhe@redhat.com
Changelog:
v6->v7:
Fix code bugs that test robot reported on mips and ia64.
Add error code description in reparent_resources() according to
Andy's comment, and fix minor log typo.
v5->v6:
Fix code style problems in reparent_resources() and use existing
error codes, according to Andy's suggestion.
Fix bugs test robot reported.
v4->v5:
Add new patch 0001 to move duplicated reparent_resources() to
kernel/resource.c to make it be shared by different ARCH-es.
Fix several code bugs reported by test robot on ARCH powerpc and
microblaze.
v3->v4:
Fix several bugs test robot reported. Rewrite cover letter and patch
log according to reviewer's comment.
v2->v3:
Rename resource functions first_child() and sibling() to
resource_first_chils() and resource_sibling(). Dan suggested this.
Move resource_first_chils() and resource_sibling() to linux/ioport.h
and make them as inline function. Rob suggested this. Accordingly add
linux/list.h including in linux/ioport.h, please help review if this
bring efficiency degradation or code redundancy.
The change on struct resource {} bring two pointers of size increase,
mention this in git log to make it more specifically, Rob suggested
this.
v1->v2:
Use list_head instead to link resource siblings. This is suggested by
Andrew.
Rewrite walk_system_ram_res_rev() after list_head is taken to link
resouce siblings.
Baoquan He (4):
resource: Move reparent_resources() to kernel/resource.c and make it
public
resource: Use list_head to link sibling resource
resource: add walk_system_ram_res_rev()
kexec_file: Load kernel at top of system RAM if required
arch/arm/plat-samsung/pm-check.c | 6 +-
arch/ia64/sn/kernel/io_init.c | 2 +-
arch/microblaze/pci/pci-common.c | 41 +----
arch/mips/pci/pci-rc32434.c | 12 +-
arch/powerpc/kernel/pci-common.c | 39 +---
arch/sparc/kernel/ioport.c | 2 +-
arch/xtensa/include/asm/pci-bridge.h | 4 +-
drivers/eisa/eisa-bus.c | 2 +
drivers/gpu/drm/drm_memory.c | 3 +-
drivers/gpu/drm/gma500/gtt.c | 5 +-
drivers/hv/vmbus_drv.c | 52 +++---
drivers/input/joystick/iforce/iforce-main.c | 4 +-
drivers/nvdimm/namespace_devs.c | 6 +-
drivers/nvdimm/nd.h | 5 +-
drivers/of/address.c | 4 +-
drivers/parisc/lba_pci.c | 4 +-
drivers/pci/controller/vmd.c | 8 +-
drivers/pci/probe.c | 2 +
drivers/pci/setup-bus.c | 2 +-
include/linux/ioport.h | 21 ++-
kernel/kexec_file.c | 2 +
kernel/resource.c | 266 ++++++++++++++++++----------
22 files changed, 260 insertions(+), 232 deletions(-)
--
2.13.6
Powered by blists - more mailing lists