[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <612de3c34f4986ac3ee6040af200a0e179acdcbd.camel@perches.com>
Date: Tue, 24 Jul 2018 17:33:07 -0700
From: Joe Perches <joe@...ches.com>
To: pheragu@...eaurora.org, Apw <apw@...onical.com>
Cc: Linux Kernel <linux-kernel@...r.kernel.org>,
Bryanh <bryanh@...eaurora.org>, Ckadabi <ckadabi@...eaurora.org>,
Tsoni <tsoni@...eaurora.org>
Subject: Re: Reminder to review a few patches sent two weeks ago
On Tue, 2018-07-24 at 14:56 -0700, pheragu@...eaurora.org wrote:
> A reminder to review a few patches I had sent last week. Below are the
> links for the patches.
>
> https://lkml.org/lkml/2018/7/5/798
I have no fundamental object to this one, but
the 80 column use is unnecessary and should be
coalesced before it can be applied.
Perhaps:
# warn about #if 1
if ($line =~ /^.\s*\#\s*if\s+1\b/) {
WARN("IF_1",
"Consider removing the #if 1 and its #endif\n" . $herecurr);
}
> http://lists-archives.com/linux-kernel/29168320-checkpatch-check-for-invalid-return-codes.html
This one has I think too many existing uses of
things like "return -1;"
$ git grep -P "return\s*\-\d+\s*;" | wc -l
9929
How many of these are actually appropriate?
Also, no space is required between return and -1
by c90 and this should use $Int so it should be:
if ($line =~ /\breturn\s*\-\$Int\s*;/) {
etc...
Powered by blists - more mailing lists