lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [thread-next>] [day] [month] [year] [list]
Date:   Thu, 26 Jul 2018 20:24:10 +0100
From:   John Whitmore <johnfwhitmore@...il.com>
To:     linux-kernel@...r.kernel.org
Cc:     devel@...verdev.osuosl.org, gregkh@...uxfoundation.org,
        John Whitmore <johnfwhitmore@...il.com>
Subject: [PATCH 00/16] staging:rtl8192u: Proxy Structures?

This series of patches contains coding style changes.

There is one type of change, proxy structures, which whilst not flagged
by checkpatch, as an issue, I have changed. I can't see the purpose of
defining a structure, in this case arrays, and then using a #define to
name the structure something else.

This may well be a pattern which I'm not familiar with, in which case
the patches can be rejected, and I'll have learned something, but I thought
I'd better explicitly mention it, as I'm assuming that there is not actual
point to the practice.

Apart from that all the rest are simple coding style changes.

John Whitmore (16):
  staging:rtl8192u: Rename SwChnlCmd - Style
  staging:rtl8192u: Rename CmdID - Style
  staging:rtl8192u: Rename Para1 > para_1 - Style
  staging:rtl8192u: Rename Para2 to para_2 - style
  staging:rtl8192u: Rename msDelay to ms_delay - Style
  staging:rtl8192u: Remove proxy struct rtl819XMACPHY_Array_PG - Style
  staging:rtl8192u: Remove proxy struct rtl819XPHY_REG_1T2RArray - Style
  staging:rtl8192u: Remove proxy array rtl819XAGCTAB_Array - Style
  staging:rtl8192u: Remove proxy rtl819XRadioA_Array - Style
  staging:rtl8192u: Remove proxy rtl819XRadioB_Array - Style
  staging:rtl8192u: Remove proxy rtl819XRadioC_Array - Style
  staging:rtl8192u: Remove proxy rtl819XRadioD_Array - Style
  staging:rtl8192u: Rename HW90_BLOCK_E - Style
  staging:rtl8192u: Rename RF90_RADIO_PATH_E - Style
  staging:rtl8192u: Remove repeated definitions - Style
  staging:rtl8192u: Rename eRFPath - Style

 drivers/staging/rtl8192u/r8190_rtl8256.c |  42 ++---
 drivers/staging/rtl8192u/r8192U_core.c   |   4 +-
 drivers/staging/rtl8192u/r819xU_phy.c    | 230 +++++++++++------------
 drivers/staging/rtl8192u/r819xU_phy.h    |  42 ++---
 4 files changed, 147 insertions(+), 171 deletions(-)

-- 
2.18.0

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ