lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Message-ID: <tip-d018031f562b9c2eff038969ab1955a370c52d8f@git.kernel.org>
Date:   Mon, 30 Jul 2018 12:33:53 -0700
From:   tip-bot for Mukesh Ojha <tipbot@...or.com>
To:     linux-tip-commits@...r.kernel.org
Cc:     mojha@...eaurora.org, hpa@...or.com, malat@...ian.org,
        tglx@...utronix.de, brendan.jackman@....com,
        jiangshanlai@...il.com, peterz@...radead.org, mingo@...nel.org,
        linux-kernel@...r.kernel.org
Subject: [tip:smp/hotplug] cpu/hotplug: Clarify CPU hotplug step name for
 timers

Commit-ID:  d018031f562b9c2eff038969ab1955a370c52d8f
Gitweb:     https://git.kernel.org/tip/d018031f562b9c2eff038969ab1955a370c52d8f
Author:     Mukesh Ojha <mojha@...eaurora.org>
AuthorDate: Tue, 24 Jul 2018 20:17:48 +0530
Committer:  Thomas Gleixner <tglx@...utronix.de>
CommitDate: Mon, 30 Jul 2018 21:30:52 +0200

cpu/hotplug: Clarify CPU hotplug step name for timers

After commit 249d4a9b3246 ("timers: Reinitialize per cpu bases on hotplug")
i.e. the introduction of state CPUHP_TIMERS_PREPARE instead of
CPUHP_TIMERS_DEAD the step name "timers:dead" is not longer accurate.

Rename it to "timers:prepare".

[ tglx: Massaged changelog ]

Signed-off-by: Mukesh Ojha <mojha@...eaurora.org>
Signed-off-by: Thomas Gleixner <tglx@...utronix.de>
Cc: gkohli@...eaurora.org
Cc: neeraju@...eaurora.org
Cc: Peter Zijlstra <peterz@...radead.org>
Cc: Lai Jiangshan <jiangshanlai@...il.com>
Cc: Brendan Jackman <brendan.jackman@....com>
Cc: Mathieu Malaterre <malat@...ian.org>
Link: https://lkml.kernel.org/r/1532443668-26810-1-git-send-email-mojha@codeaurora.org

---
 kernel/cpu.c | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/kernel/cpu.c b/kernel/cpu.c
index 0db8938fbb23..8e6606ac3d72 100644
--- a/kernel/cpu.c
+++ b/kernel/cpu.c
@@ -1274,7 +1274,7 @@ static struct cpuhp_step cpuhp_hp_states[] = {
 	 * otherwise a RCU stall occurs.
 	 */
 	[CPUHP_TIMERS_PREPARE] = {
-		.name			= "timers:dead",
+		.name			= "timers:prepare",
 		.startup.single		= timers_prepare_cpu,
 		.teardown.single	= timers_dead_cpu,
 	},

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ