[<prev] [next>] [thread-next>] [day] [month] [year] [list]
Message-Id: <20180801215759.103758-1-ndesaulniers@google.com>
Date: Wed, 1 Aug 2018 14:57:59 -0700
From: Nick Desaulniers <ndesaulniers@...gle.com>
To: davem@...emloft.net
Cc: natechancellor@...il.com,
Nick Desaulniers <ndesaulniers@...gle.com>,
netdev@...r.kernel.org, linux-kernel@...r.kernel.org
Subject: [PATCH] inet/connection_sock: prefer _THIS_IP_ to current_text_addr
As part of the effort to reduce the code duplication between _THIS_IP_
and current_text_addr(), let's consolidate callers of
current_text_addr() to use _THIS_IP_.
Signed-off-by: Nick Desaulniers <ndesaulniers@...gle.com>
---
include/net/inet_connection_sock.h | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)
diff --git a/include/net/inet_connection_sock.h b/include/net/inet_connection_sock.h
index 0a6c9e0f2b5a..f2a87e85c07b 100644
--- a/include/net/inet_connection_sock.h
+++ b/include/net/inet_connection_sock.h
@@ -19,6 +19,7 @@
#include <linux/string.h>
#include <linux/timer.h>
#include <linux/poll.h>
+#include <linux/kernel.h>
#include <net/inet_sock.h>
#include <net/request_sock.h>
@@ -224,7 +225,7 @@ static inline void inet_csk_reset_xmit_timer(struct sock *sk, const int what,
if (when > max_when) {
pr_debug("reset_xmit_timer: sk=%p %d when=0x%lx, caller=%p\n",
- sk, what, when, current_text_addr());
+ sk, what, when, (void *)_THIS_IP_);
when = max_when;
}
--
2.18.0.597.ga71716f1ad-goog
Powered by blists - more mailing lists