[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Message-ID: <20180801154841.GA10824@ziepe.ca>
Date: Wed, 1 Aug 2018 09:48:41 -0600
From: Jason Gunthorpe <jgg@...pe.ca>
To: Dan Carpenter <dan.carpenter@...cle.com>
Cc: Kees Cook <keescook@...omium.org>,
Rasmus Villemoes <linux@...musvillemoes.dk>,
Leon Romanovsky <leonro@...lanox.com>,
Leon Romanovsky <leon@...nel.org>,
Bart Van Assche <Bart.VanAssche@....com>,
Doug Ledford <dledford@...hat.com>, linux-rdma@...r.kernel.org,
linux-kernel@...r.kernel.org
Subject: Re: [PATCH v2 1/3] overflow.h: Add arithmetic shift helper
On Wed, Aug 01, 2018 at 11:07:24AM +0300, Dan Carpenter wrote:
> On Wed, Aug 01, 2018 at 10:57:44AM +0300, Dan Carpenter wrote:
> > The idea is nice, but I don't like the API. The "_overflow" feels too
> > specific because maybe we could check for other things in the future.
> > Normally boolean macros should say they are boolean in the name and I
> > would prefer if it returned zero on failure.
> >
> > if (!checked_shift(dest, mask, shift)) {
> > if (!shift_ok(dest, mask, shift)) {
> > if (!safe_shift(dest, mask, shift)) {
>
> Huh... It turns out I put the argument order different as well.
>
> If we wanted to keep it returning 1 on failure then some other names
> are:
>
> if (shift_failed(dest, mask, shift)) {
> if (shift_error(dest, mask, shift)) {
> if (shift_overflow(dest, mask, shift)) {
I think this ship has sailed, the convention for these tests is
already established in overflow.h. ie:
check_add_overflow
check_sub_overflow
check_mul_overflow
Jason
Powered by blists - more mailing lists