[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-Id: <20180804091859.6729-8-johnfwhitmore@gmail.com>
Date: Sat, 4 Aug 2018 10:18:59 +0100
From: John Whitmore <johnfwhitmore@...il.com>
To: linux-kernel@...r.kernel.org
Cc: devel@...verdev.osuosl.org, gregkh@...uxfoundation.org,
John Whitmore <johnfwhitmore@...il.com>
Subject: [PATCH 7/7] staging:rtl8192u: Replace magic number with defined constant - Style
Replace the magic number '8' with defined constant which is normally used
'MAX_DEV_ADDR_SIZE'.
This is a coding style change which should have no impact on runtime code
execution.
Signed-off-by: John Whitmore <johnfwhitmore@...il.com>
---
drivers/staging/rtl8192u/ieee80211/ieee80211_softmac.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/staging/rtl8192u/ieee80211/ieee80211_softmac.c b/drivers/staging/rtl8192u/ieee80211/ieee80211_softmac.c
index 51cb5e4658b0..212cc9ccbb96 100644
--- a/drivers/staging/rtl8192u/ieee80211/ieee80211_softmac.c
+++ b/drivers/staging/rtl8192u/ieee80211/ieee80211_softmac.c
@@ -217,7 +217,7 @@ inline void softmac_mgmt_xmit(struct sk_buff *skb, struct ieee80211_device *ieee
struct rtl_80211_hdr_3addr *header =
(struct rtl_80211_hdr_3addr *)skb->data;
- struct cb_desc *tcb_desc = (struct cb_desc *)(skb->cb + 8);
+ struct cb_desc *tcb_desc = (struct cb_desc *)(skb->cb + MAX_DEV_ADDR_SIZE);
spin_lock_irqsave(&ieee->lock, flags);
--
2.18.0
Powered by blists - more mailing lists