[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <20180820171855.GA3993@tower.DHCP.thefacebook.com>
Date: Mon, 20 Aug 2018 10:19:01 -0700
From: Roman Gushchin <guro@...com>
To: Matthew Wilcox <willy@...radead.org>
CC: <linux-mm@...ck.org>, <linux-kernel@...r.kernel.org>,
<kernel-team@...com>, Andrew Morton <akpm@...ux-foundation.org>,
Johannes Weiner <hannes@...xchg.org>,
Michal Hocko <mhocko@...nel.org>, Tejun Heo <tj@...nel.org>,
Rik van Riel <riel@...riel.com>,
Konstantin Khlebnikov <koct9i@...il.com>
Subject: Re: [PATCH RFC] mm: don't miss the last page because of round-off
error
On Fri, Aug 17, 2018 at 06:22:13PM -0700, Matthew Wilcox wrote:
> On Fri, Aug 17, 2018 at 04:18:34PM -0700, Roman Gushchin wrote:
> > - scan = div64_u64(scan * fraction[file],
> > - denominator);
> > + if (scan > 1)
> > + scan = div64_u64(scan * fraction[file],
> > + denominator);
>
> Wouldn't we be better off doing a div_round_up? ie:
>
> scan = div64_u64(scan * fraction[file] + denominator - 1, denominator);
>
> although i'd rather hide that in a new macro in math64.h than opencode it
> here.
Good idea! Will do in v2.
Thanks!
Powered by blists - more mailing lists