[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <CAKwvOd=U0aMsUmBytK7vq=ORj+Npw7FqZ50EMEJPnmTG15N7dg@mail.gmail.com>
Date: Mon, 20 Aug 2018 10:58:41 -0700
From: Nick Desaulniers <ndesaulniers@...gle.com>
To: Thomas Gleixner <tglx@...utronix.de>, mingo@...hat.com,
hpa@...or.com, "Eric W . Biederman" <ebiederm@...ssion.com>,
Simon Horman <horms@...ge.net.au>,
Andrew Morton <akpm@...ux-foundation.org>,
Linus Torvalds <torvalds@...ux-foundation.org>
Cc: Nathan Chancellor <natechancellor@...il.com>, x86@...nel.org,
Philippe Ombredanne <pombredanne@...b.com>,
Kate Stewart <kstewart@...uxfoundation.org>,
Greg KH <gregkh@...uxfoundation.org>,
LKML <linux-kernel@...r.kernel.org>, kexec@...ts.infradead.org
Subject: Re: [PATCH] x86/kexec: prefer _THIS_IP_ to current_text_addr
+ akpm, Linus
Bumping for review.
On Mon, Aug 13, 2018 at 2:32 PM Nick Desaulniers
<ndesaulniers@...gle.com> wrote:
>
> + Simon (kexec)
>
> bumping for review.
> On Wed, Aug 8, 2018 at 4:06 PM Nick Desaulniers <ndesaulniers@...gle.com> wrote:
> >
> > bumping for review
> > On Wed, Aug 1, 2018 at 2:08 PM Nick Desaulniers <ndesaulniers@...gle.com> wrote:
> > >
> > > As part of the effort to reduce the code duplication between _THIS_IP_
> > > and current_text_addr(), let's consolidate callers of
> > > current_text_addr() to use _THIS_IP_.
> > >
> > > Signed-off-by: Nick Desaulniers <ndesaulniers@...gle.com>
> > > ---
> > > arch/x86/include/asm/kexec.h | 3 ++-
> > > 1 file changed, 2 insertions(+), 1 deletion(-)
> > >
> > > diff --git a/arch/x86/include/asm/kexec.h b/arch/x86/include/asm/kexec.h
> > > index f327236f0fa7..86924d594ecd 100644
> > > --- a/arch/x86/include/asm/kexec.h
> > > +++ b/arch/x86/include/asm/kexec.h
> > > @@ -21,6 +21,7 @@
> > > #ifndef __ASSEMBLY__
> > >
> > > #include <linux/string.h>
> > > +#include <linux/kernel.h>
> > >
> > > #include <asm/page.h>
> > > #include <asm/ptrace.h>
> > > @@ -132,7 +133,7 @@ static inline void crash_setup_regs(struct pt_regs *newregs,
> > > asm volatile("movl %%cs, %%eax;" :"=a"(newregs->cs));
> > > asm volatile("pushfq; popq %0" :"=m"(newregs->flags));
> > > #endif
> > > - newregs->ip = (unsigned long)current_text_addr();
> > > + newregs->ip = _THIS_IP_;
> > > }
> > > }
> > >
> > > --
> > > 2.18.0.597.ga71716f1ad-goog
> > >
--
Thanks,
~Nick Desaulniers
Powered by blists - more mailing lists