lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  PHC 
Open Source and information security mailing list archives
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Date:   Tue, 21 Aug 2018 18:27:34 +0000
From:   "Ghannam, Yazen" <>
To:     Borislav Petkov <>
CC:     "" <>,
        "" <>,
        "" <>,
        "" <>
Subject: RE: [PATCH 2/2] x86/MCE/AMD: Skip creating kobjects with NULL names

> -----Original Message-----
> From: Borislav Petkov <>
> Sent: Tuesday, August 21, 2018 8:16 AM
> To: Ghannam, Yazen <>
> Cc:;;
> Subject: Re: [PATCH 2/2] x86/MCE/AMD: Skip creating kobjects with NULL
> names
> On Thu, Aug 16, 2018 at 06:46:33PM +0000, Ghannam, Yazen wrote:
> > Future SMCA systems may have banks whose MCA_IPID is not known so we
> You lost me here. How would the IPID not be known? Are you talking about
> an old kernel running on new HW and thus the HardwareID in its MCA_IPID
> to be unknown to the old kernel?

Yes, that's right: old kernel on new HW.

> > In the past, the sysfs entries were named something like "th_bank#" before
> > each bank was given a more descriptive name. We can go back to this format
> > as a fallback for unrecognized bank types. This will fix the issue with sysfs
> > failing and also the interface will still work on new hardware.
> You could do: th_bank#<HardwareID> so that we can find what it is by
> grepping the PPR.

Good idea. Will do.


Powered by blists - more mailing lists