[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <20180823232747.072af43d@bbrezillon>
Date: Thu, 23 Aug 2018 23:27:47 +0200
From: Boris Brezillon <boris.brezillon@...tlin.com>
To: "Gustavo A. R. Silva" <gustavo@...eddedor.com>
Cc: Harvey Hunt <harveyhuntnexus@...il.com>,
Miquel Raynal <miquel.raynal@...tlin.com>,
Richard Weinberger <richard@....at>,
David Woodhouse <dwmw2@...radead.org>,
Brian Norris <computersforpeace@...il.com>,
Marek Vasut <marek.vasut@...il.com>,
linux-mtd@...ts.infradead.org, linux-kernel@...r.kernel.org,
Kees Cook <keescook@...omium.org>
Subject: Re: [PATCH] mtd: rawnand: jz4780: use struct_size() in
devm_kzalloc()
On Thu, 23 Aug 2018 14:33:32 -0500
"Gustavo A. R. Silva" <gustavo@...eddedor.com> wrote:
> One of the more common cases of allocation size calculations is finding
> the size of a structure that has a zero-sized array at the end, along
> with memory for some number of elements for that array. For example:
>
> struct foo {
> int stuff;
> void *entry[];
> };
>
> instance = devm_kzalloc(dev, sizeof(struct foo) + sizeof(void *) * count, GFP_KERNEL);
>
> Instead of leaving these open-coded and prone to type mistakes, we can
> now use the new struct_size() helper:
>
> instance = devm_kzalloc(dev, struct_size(instance, entry, count), GFP_KERNEL);
Oh, I didn't know about that one. That's nice!
>
> Signed-off-by: Gustavo A. R. Silva <gustavo@...eddedor.com>
Reviewed-by: Boris Brezillon <boris.brezillon@...tlin.com>
> ---
> drivers/mtd/nand/raw/jz4780_nand.c | 2 +-
> 1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/drivers/mtd/nand/raw/jz4780_nand.c b/drivers/mtd/nand/raw/jz4780_nand.c
> index db4fa60..ac62395 100644
> --- a/drivers/mtd/nand/raw/jz4780_nand.c
> +++ b/drivers/mtd/nand/raw/jz4780_nand.c
> @@ -352,7 +352,7 @@ static int jz4780_nand_probe(struct platform_device *pdev)
> return -ENODEV;
> }
>
> - nfc = devm_kzalloc(dev, sizeof(*nfc) + (sizeof(nfc->cs[0]) * num_banks), GFP_KERNEL);
> + nfc = devm_kzalloc(dev, struct_size(nfc, cs, num_banks), GFP_KERNEL);
> if (!nfc)
> return -ENOMEM;
>
Powered by blists - more mailing lists