[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Message-ID: <2639880.ggikvLCEDc@phil>
Date: Wed, 29 Aug 2018 13:41:50 +0200
From: Heiko Stuebner <heiko@...ech.de>
To: "Gustavo A. R. Silva" <gustavo@...eddedor.com>
Cc: Sandy Huang <hjc@...k-chips.com>, David Airlie <airlied@...ux.ie>,
dri-devel@...ts.freedesktop.org,
linux-arm-kernel@...ts.infradead.org,
linux-rockchip@...ts.infradead.org, linux-kernel@...r.kernel.org,
Kees Cook <keescook@...omium.org>
Subject: Re: [PATCH] drm/rockchip: Use struct_size() in devm_kzalloc()
Am Sonntag, 26. August 2018, 20:47:12 CEST schrieb Gustavo A. R. Silva:
> One of the more common cases of allocation size calculations is finding
> the size of a structure that has a zero-sized array at the end, along
> with memory for some number of elements for that array. For example:
>
> struct foo {
> int stuff;
> void *entry[];
> };
>
> instance = devm_kzalloc(dev, sizeof(struct foo) + sizeof(void *) * count, GFP_KERNEL);
>
> or, like in this particular case:
>
> size = sizeof(struct foo) + sizeof(void *) * count;
> instance = devm_kzalloc(dev, size, GFP_KERNEL);
>
> Instead of leaving these open-coded and prone to type mistakes, we can
> now use the new struct_size() helper:
>
> instance = devm_kzalloc(dev, struct_size(instance, entry, count),
> GFP_KERNEL);
>
> This issue was detected with the help of Coccinelle.
>
> Signed-off-by: Gustavo A. R. Silva <gustavo@...eddedor.com>
applied to drm-misc with Kees' Review
Thanks
Heiko
Powered by blists - more mailing lists