lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <8d6457cf-a105-3d88-bd38-d46b24f70501@suse.com>
Date:   Fri, 14 Sep 2018 11:12:13 +0200
From:   Juergen Gross <jgross@...e.com>
To:     Dongli Zhang <dongli.zhang@...cle.com>,
        xen-devel@...ts.xenproject.org, linux-kernel@...r.kernel.org
Cc:     boris.ostrovsky@...cle.com, paul.durrant@...rix.com,
        wei.liu2@...rix.com, konrad.wilk@...cle.com, roger.pau@...rix.com,
        srinivas.eeda@...cle.com
Subject: Re: [PATCH 5/6] xenbus: process be_watch events in xenwatch
 multithreading

On 14/09/18 09:34, Dongli Zhang wrote:
> This is the 5th patch of a (6-patch) patch set.
> 
> With this patch, watch event in relative path pattern
> 'backend/<pvdev>/<domid>i/...' can be processed in per-domU xenwatch

superfluous "i" ----------^

> thread.
> 
> Signed-off-by: Dongli Zhang <dongli.zhang@...cle.com>
> ---
>  drivers/xen/xenbus/xenbus_probe.c         |  2 +-
>  drivers/xen/xenbus/xenbus_probe_backend.c | 32 +++++++++++++++++++++++++++++++
>  include/xen/xenbus.h                      |  2 ++
>  3 files changed, 35 insertions(+), 1 deletion(-)
> 
> diff --git a/drivers/xen/xenbus/xenbus_probe.c b/drivers/xen/xenbus/xenbus_probe.c
> index ba0644c..aa1b15a 100644
> --- a/drivers/xen/xenbus/xenbus_probe.c
> +++ b/drivers/xen/xenbus/xenbus_probe.c
> @@ -552,7 +552,7 @@ int xenbus_probe_devices(struct xen_bus_type *bus)
>  }
>  EXPORT_SYMBOL_GPL(xenbus_probe_devices);
>  
> -static unsigned int char_count(const char *str, char c)
> +unsigned int char_count(const char *str, char c)

Please change the name of the function when making it globally
visible, e.g. by prefixing "xenbus_".

Generally I think you don't need to use it below.

>  {
>  	unsigned int i, ret = 0;
>  
> diff --git a/drivers/xen/xenbus/xenbus_probe_backend.c b/drivers/xen/xenbus/xenbus_probe_backend.c
> index b0bed4f..50df86a 100644
> --- a/drivers/xen/xenbus/xenbus_probe_backend.c
> +++ b/drivers/xen/xenbus/xenbus_probe_backend.c
> @@ -211,9 +211,41 @@ static void backend_changed(struct xenbus_watch *watch,
>  	xenbus_dev_changed(path, &xenbus_backend);
>  }
>  
> +static domid_t path_to_domid(const char *path)
> +{
> +	const char *p = path;
> +	domid_t domid = 0;
> +
> +	while (*p) {
> +		if (*p < '0' || *p > '9')
> +			break;
> +		domid = (domid << 3) + (domid << 1) + (*p - '0');

reinventing atoi()?

Please don't do that. kstrtou16() seems to be a perfect fit.

> +		p++;
> +	}
> +
> +	return domid;
> +}
> +
> +/* path: backend/<pvdev>/<domid>/... */
> +static domid_t be_get_domid(struct xenbus_watch *watch,
> +			    const char *path,
> +			    const char *token)
> +{
> +	const char *p = path;
> +
> +	if (char_count(path, '/') < 2)
> +		return 0;
> +
> +	p = strchr(p, '/') + 1;
> +	p = strchr(p, '/') + 1;

Drop the call of char_count() above and test p for being non-NULL
after each call of strchr?


Juergen

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ