lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:   Tue, 25 Sep 2018 09:04:11 +0800
From:   Chao Fan <fanc.fnst@...fujitsu.com>
To:     Kees Cook <keescook@...omium.org>
CC:     linux-efi <linux-efi@...r.kernel.org>,
        ACPI Devel Maling List <linux-acpi@...r.kernel.org>,
        Thomas Gleixner <tglx@...utronix.de>,
        Ingo Molnar <mingo@...hat.com>,
        "H. Peter Anvin" <hpa@...or.com>, X86 ML <x86@...nel.org>,
        LKML <linux-kernel@...r.kernel.org>, Baoquan He <bhe@...hat.com>,
        "Rafael J. Wysocki" <rjw@...ysocki.net>,
        Len Brown <lenb@...nel.org>,
        Ard Biesheuvel <ard.biesheuvel@...aro.org>,
        <indou.takao@...fujitsu.com>, <caoj.fnst@...fujitsu.com>
Subject: Re: [PATCH v7 3/3] x86/boot/KASLR: Limit kaslr to choosing the
 immovable memory

On Sat, Sep 22, 2018 at 08:48:53AM -0700, Kees Cook wrote:
>On Thu, Sep 13, 2018 at 3:46 AM, Chao Fan <fanc.fnst@...fujitsu.com> wrote:
>> +#ifdef CONFIG_MEMORY_HOTREMOVE
>> +       /*
>> +        * If immovable memory found, filter the intersection between
>> +        * immovable memory and region to slots_count.
>> +        * Otherwise, go on old code.
>> +        */
>> +       for (i = 0; i < num_immovable_mem; i++) {
>> +               struct mem_vector entry;
>> +               unsigned long long start, end, entry_end, region_end;
>> +
>> +               start = immovable_mem[i].start;
>> +               end = start + immovable_mem[i].size;
>> +               region_end = region->start + region->size;
>> +
>> +               entry.start = clamp(region->start, start, end);
>> +               entry_end = clamp(region_end, start, end);
>> +
>> +               if (entry.start + image_size < entry_end) {
>
>Can this logic be rewritten to use the existing mem_overlaps() check
>instead? I think that would make it much more readable.
>

Sure, I will reuse mem_overlaps() instead of this logical.

>Otherwise, yes, this all looks fine.

Thank you for the review.

Thanks,
Chao Fan

>
>-Kees
>
>> +                       entry.size = entry_end - entry.start;
>> +                       slots_count(&entry, minimum, image_size);
>> +
>> +                       if (slot_area_index == MAX_SLOT_AREA) {
>> +                               debug_putstr("Aborted e820/efi memmap scan (slot_areas full)!\n");
>> +                               return 1;
>> +                       }
>> +               }
>> +       }
>> +       return 0;
>> +#endif
>> +}
>> +
>>  #ifdef CONFIG_EFI
>>  /*
>>   * Returns true if mirror region found (and must have been processed
>> @@ -720,11 +775,8 @@ process_efi_entries(unsigned long minimum, unsigned long image_size)
>>
>>                 region.start = md->phys_addr;
>>                 region.size = md->num_pages << EFI_PAGE_SHIFT;
>> -               process_mem_region(&region, minimum, image_size);
>> -               if (slot_area_index == MAX_SLOT_AREA) {
>> -                       debug_putstr("Aborted EFI scan (slot_areas full)!\n");
>> +               if (process_mem_region(&region, minimum, image_size))
>>                         break;
>> -               }
>>         }
>>         return true;
>>  }
>> @@ -751,11 +803,8 @@ static void process_e820_entries(unsigned long minimum,
>>                         continue;
>>                 region.start = entry->addr;
>>                 region.size = entry->size;
>> -               process_mem_region(&region, minimum, image_size);
>> -               if (slot_area_index == MAX_SLOT_AREA) {
>> -                       debug_putstr("Aborted e820 scan (slot_areas full)!\n");
>> +               if (process_mem_region(&region, minimum, image_size))
>>                         break;
>> -               }
>>         }
>>  }
>>
>> --
>> 2.17.1
>>
>>
>>
>
>
>
>-- 
>Kees Cook
>Pixel Security
>
>


Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ