lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:   Thu, 4 Oct 2018 09:53:39 +0200
From:   "Rafael J. Wysocki" <rafael@...nel.org>
To:     Peter Zijlstra <peterz@...radead.org>
Cc:     "Rafael J. Wysocki" <rjw@...ysocki.net>,
        Linux PM <linux-pm@...r.kernel.org>,
        Linux Kernel Mailing List <linux-kernel@...r.kernel.org>,
        Daniel Lezcano <daniel.lezcano@...aro.org>
Subject: Re: [PATCH 3/6] cpuidle: menu: Get rid of first_idx from menu_select()

On Thu, Oct 4, 2018 at 9:46 AM Peter Zijlstra <peterz@...radead.org> wrote:
>
> On Tue, Oct 02, 2018 at 11:44:06PM +0200, Rafael J. Wysocki wrote:
> >       idx = -1;
> > -     for (i = first_idx; i < drv->state_count; i++) {
> > +     for (i = 0; i < drv->state_count; i++) {
> >               struct cpuidle_state *s = &drv->states[i];
> >               struct cpuidle_state_usage *su = &dev->states_usage[i];
> >
> >               if (s->disabled || su->disable)
> >                       continue;
> > +
> >               if (idx == -1)
> >                       idx = i; /* first enabled state */
> > +
> >               if (s->target_residency > predicted_us) {
> > +                     /*
> > +                      * Use a physical idle state, not busy polling, unless
> > +                      * a timer is going to trigger really really soon.
> > +                      */
> > +                     if ((drv->states[idx].flags & CPUIDLE_FLAG_POLLING) &&
> > +                         i == idx + 1 && latency_req > s->exit_latency &&
> > +                         data->next_timer_us > max_t(unsigned int, 20,
> > +                                                     s->target_residency)) {
>
> Not new in this patch, but this is where I really noticed it; that 20,
> should that not be something like: POLL_IDLE_TIME_LIMIT / NSEC_PER_USEC
> ?

The POLL_IDLE_TIME_LIMIT is how much time we allow it to spin in
idle_poll() and I'm not sure it is related.  Besides, I want it to go
away actually (https://patchwork.kernel.org/patch/10624117/).

I could use a separate symbol for this particular magic number, but it
has been magic forever and it is used just in this one place, so ...

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ