[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <25951d99-8ba7-5c9e-938e-baf92395f9e0@intel.com>
Date: Thu, 11 Oct 2018 16:47:29 -0700
From: Dave Hansen <dave.hansen@...el.com>
To: Rick Edgecombe <rick.p.edgecombe@...el.com>,
kernel-hardening@...ts.openwall.com, daniel@...earbox.net,
keescook@...omium.org, catalin.marinas@....com,
will.deacon@....com, davem@...emloft.net, tglx@...utronix.de,
mingo@...hat.com, bp@...en8.de, x86@...nel.org, arnd@...db.de,
jeyu@...nel.org, linux-arm-kernel@...ts.infradead.org,
linux-kernel@...r.kernel.org, linux-mips@...ux-mips.org,
linux-s390@...r.kernel.org, sparclinux@...r.kernel.org,
linux-fsdevel@...r.kernel.org, linux-arch@...r.kernel.org
Cc: kristen@...ux.intel.com, arjan@...ux.intel.com,
deneen.t.dock@...el.com
Subject: Re: [PATCH v2 4/7] arm64/modules: Add rlimit checking for arm64
modules
On 10/11/2018 04:31 PM, Rick Edgecombe wrote:
> + if (check_inc_mod_rlimit(size))
> + return NULL;
> +
> p = __vmalloc_node_range(size, MODULE_ALIGN, module_alloc_base,
> module_alloc_base + MODULES_VSIZE,
> gfp_mask, PAGE_KERNEL_EXEC, 0,
> @@ -65,6 +68,8 @@ void *module_alloc(unsigned long size)
> return NULL;
> }
>
> + update_mod_rlimit(p, size);
Is there a reason we couldn't just rename all of the existing per-arch
module_alloc() calls to be called, say, "arch_module_alloc()", then put
this new rlimit code in a generic helper that does:
if (check_inc_mod_rlimit(size))
return NULL;
p = arch_module_alloc(...);
...
update_mod_rlimit(p, size);
Powered by blists - more mailing lists