[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <CADvQ+rH5FTzgQN==EwQn_MogDeGR1hnScd=pyuRqHXB=QKYo_Q@mail.gmail.com>
Date: Wed, 17 Oct 2018 20:10:50 -0300
From: Leonardo Bras <leobras.c@...il.com>
To: helen@...keco.de
Cc: lkcamp@...ts.libreplanetbr.org, x86@...nel.org,
linux-kbuild@...r.kernel.org, Matthew Wilcox <willy6545@...il.com>,
linux-kernel <linux-kernel@...r.kernel.org>,
Masahiro Yamada <yamada.masahiro@...ionext.com>,
Ingo Molnar <mingo@...hat.com>, Borislav Petkov <bp@...en8.de>,
Andy Lutomirski <luto@...nel.org>,
"H. Peter Anvin" <hpa@...or.com>,
Michal Marek <michal.lkml@...kovi.net>,
Thomas Gleixner <tglx@...utronix.de>
Subject: Re: [Lkcamp] [PATCH 2/4] Renames variable to fix shadow warning.
Hello Helen,
Thanks for the suggestions!
On Tue, Oct 16, 2018 at 11:57 PM Helen Koike <helen@...keco.de> wrote:
>
> Hi Leonardo,
>
> Thanks for the patch, just some small comments below.
>
> Please, check previous log messages with git log
> arch/x86/entry/vdso/vdso2c.h, you will see that most patches had the
> prefix "x86/vdso:" in the commit message.
Ok, added! This change will be available on v2.
>
> On 10/16/18 9:08 PM, Leonardo Brás wrote:
> > Renames the char variable to avoid shadowing a variable previously
> > declared on this function.
> >
> > Signed-off-by: Leonardo Brás <leobras.c@...il.com>
> > ---
> > arch/x86/entry/vdso/vdso2c.h | 4 ++--
> > 1 file changed, 2 insertions(+), 2 deletions(-)
> >
> > diff --git a/arch/x86/entry/vdso/vdso2c.h b/arch/x86/entry/vdso/vdso2c.h
> > index fa847a620f40..9466998d0f28 100644
> > --- a/arch/x86/entry/vdso/vdso2c.h
> > +++ b/arch/x86/entry/vdso/vdso2c.h
> > @@ -93,11 +93,11 @@ static void BITSFUNC(go)(void *raw_addr, size_t raw_len,
> > int k;
> > ELF(Sym) *sym = raw_addr + GET_LE(&symtab_hdr->sh_offset) +
> > GET_LE(&symtab_hdr->sh_entsize) * i;
> > - const char *name = raw_addr + GET_LE(&strtab_hdr->sh_offset) +
> > + const char *name2 = raw_addr + GET_LE(&strtab_hdr->sh_offset) +
> > GET_LE(&sym->st_name);
>
> Could you please use a more meaningful name instead of name2 please? I
> believe sym_name should be fine.
Ok, I renamed as you suggested.
Also, I renamed the "name" variable to "image_name" as Andy suggested.
This change will be available on v2.
>
> >
> > for (k = 0; k < NSYMS; k++) {
> > - if (!strcmp(name, required_syms[k].name)) {
> > + if (!strcmp(name2, required_syms[k].name)) {
> > if (syms[k]) {
> > fail("duplicate symbol %s\n",
> > required_syms[k].name);
> >
>
> Regards
> Helen
Regards,
Leonardo Bras
Powered by blists - more mailing lists