[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <20181019003715.GI1251@char.us.oracle.com>
Date: Thu, 18 Oct 2018 20:37:15 -0400
From: Konrad Rzeszutek Wilk <konrad.wilk@...cle.com>
To: Robin Murphy <robin.murphy@....com>
Cc: Christoph Hellwig <hch@....de>, Will Deacon <will.deacon@....com>,
Catalin Marinas <catalin.marinas@....com>,
linux-arm-kernel@...ts.infradead.org,
iommu@...ts.linux-foundation.org, linux-kernel@...r.kernel.org
Subject: Re: [PATCH 07/10] swiotlb: refactor swiotlb_map_page
> > + if (!dma_capable(dev, dma_addr, size) ||
> > + swiotlb_force == SWIOTLB_FORCE) {
> > + trace_swiotlb_bounced(dev, dma_addr, size, swiotlb_force);
> > + dma_addr = swiotlb_bounce_page(dev, &phys, size, dir, attrs);
> > + }
>
> FWIW I prefer the inverse condition and early return of the original code
> here, which also then allows a tail-call to swiotlb_bounce_page() (and saves
> a couple of lines), but it's no biggie.
>
> Reviewed-by: Robin Murphy <robin.murphy@....com>
I agree with Robin - it certainly makes it easier to read.
With that small change:
Reviewed-by: Konrad Rzeszutek Wilk <konrad.wilk@...cle.com>
Thank you!
>
> > - return DIRECT_MAPPING_ERROR;
> > + return dma_addr;
> > }
> > /*
> >
Powered by blists - more mailing lists