[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <1540833779.196084.56.camel@acm.org>
Date: Mon, 29 Oct 2018 10:22:59 -0700
From: Bart Van Assche <bvanassche@....org>
To: Jens Axboe <axboe@...nel.dk>, linux-block@...r.kernel.org,
linux-scsi@...r.kernel.org, linux-kernel@...r.kernel.org
Subject: Re: [PATCH 03/14] blk-mq: provide dummy blk_mq_map_queue_type()
helper
On Mon, 2018-10-29 at 10:37 -0600, Jens Axboe wrote:
> diff --git a/block/blk-mq.h b/block/blk-mq.h
> index 889f0069dd80..79c300faa7ce 100644
> --- a/block/blk-mq.h
> +++ b/block/blk-mq.h
> @@ -80,6 +80,12 @@ static inline struct blk_mq_hw_ctx *blk_mq_map_queue(struct request_queue *q,
> return q->queue_hw_ctx[set->map[0].mq_map[cpu]];
> }
>
> +static inline struct blk_mq_hw_ctx *blk_mq_map_queue_type(struct request_queue *q,
> + int type, int cpu)
> +{
> + return blk_mq_map_queue(q, cpu);
> +}
> +
> /*
> * sysfs helpers
> */
How about renaming 'type' into something like hw_ctx_type to make it more
clear what its meaning is? How about declaring both the 'type' and 'cpu'
arguments as unsigned ints?
Thanks,
Bart.
Powered by blists - more mailing lists