[<prev] [next>] [thread-next>] [day] [month] [year] [list]
Message-Id: <20181101235200.28584-1-keescook@chromium.org>
Date: Thu, 1 Nov 2018 16:51:52 -0700
From: Kees Cook <keescook@...omium.org>
To: linux-kernel@...r.kernel.org
Cc: Kees Cook <keescook@...omium.org>,
Joel Fernandes <joel@...lfernandes.org>,
Anton Vorontsov <anton@...msg.org>,
Colin Cross <ccross@...roid.com>,
Tony Luck <tony.luck@...el.com>
Subject: [PATCH 0/8] pstore improvements (pstore-next)
This is a posting of several patches I've been working on to improve
pstore. Most of it is better comments, output, and naming, but one
bug fix stands out to fix head-truncationg of compressed records.
Details in the individual patches. Review appreciated! :)
-Kees
Kees Cook (8):
pstore/ram: Standardize module name in ramoops
pstore: Do not use crash buffer for decompression
pstore/ram: Report backend assignments with finer granularity
pstore/ram: Add kern-doc for struct persistent_ram_zone
pstore: Improve and update some comments and status output
pstore: Replace open-coded << with BIT()
pstore: Remove needless lock during console writes
pstore/ram: Correctly calculate usable PRZ bytes
fs/pstore/platform.c | 92 ++++++++++++++------------------------
fs/pstore/ram.c | 19 ++++----
fs/pstore/ram_core.c | 25 +++++++++--
include/linux/pstore.h | 15 ++++---
include/linux/pstore_ram.h | 46 +++++++++++++++++--
5 files changed, 116 insertions(+), 81 deletions(-)
--
2.17.1
Powered by blists - more mailing lists