[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-Id: <E1C5FE6D-7BF7-40F5-85F9-BBD86D53EFC2@linux.ibm.com>
Date: Tue, 27 Nov 2018 23:45:40 +0200
From: Mike Rapoport <rppt@...ux.ibm.com>
To: Hugh Dickins <hughd@...gle.com>
CC: Matthew Wilcox <willy@...radead.org>,
Linus Torvalds <torvalds@...ux-foundation.org>,
Andrew Morton <akpm@...ux-foundation.org>,
Baoquan He <bhe@...hat.com>, Michal Hocko <mhocko@...e.com>,
Vlastimil Babka <vbabka@...e.cz>,
Andrea Arcangeli <aarcange@...hat.com>,
David Hildenbrand <david@...hat.com>,
Mel Gorman <mgorman@...hsingularity.net>,
David Herrmann <dh.herrmann@...il.com>,
Tim Chen <tim.c.chen@...ux.intel.com>,
Kan Liang <kan.liang@...el.com>,
Andi Kleen <ak@...ux.intel.com>,
Davidlohr Bueso <dave@...olabs.net>,
Peter Zijlstra <peterz@...radead.org>,
Christoph Lameter <cl@...ux.com>,
Nick Piggin <npiggin@...il.com>, pifang@...hat.com,
linux-kernel@...r.kernel.org, linux-mm@...ck.org
Subject: Re: [PATCHi v2] mm: put_and_wait_on_page_locked() while page is migrated
On November 27, 2018 11:08:50 PM GMT+02:00, Hugh Dickins <hughd@...gle.com> wrote:
>On Tue, 27 Nov 2018, Mike Rapoport wrote:
>> On Mon, Nov 26, 2018 at 11:27:07AM -0800, Hugh Dickins wrote:
>> >
>> > +/*
>> > + * A choice of three behaviors for wait_on_page_bit_common():
>> > + */
>> > +enum behavior {
>> > + EXCLUSIVE, /* Hold ref to page and take the bit when woken, like
>> > + * __lock_page() waiting on then setting PG_locked.
>> > + */
>> > + SHARED, /* Hold ref to page and check the bit when woken, like
>> > + * wait_on_page_writeback() waiting on PG_writeback.
>> > + */
>> > + DROP, /* Drop ref to page before wait, no check when woken,
>> > + * like put_and_wait_on_page_locked() on PG_locked.
>> > + */
>> > +};
>>
>> Can we please make it:
>>
>> /**
>> * enum behavior - a choice of three behaviors for
>wait_on_page_bit_common()
>> */
>> enum behavior {
>> /**
>> * @EXCLUSIVE: Hold ref to page and take the bit when woken,
>> * like __lock_page() waiting on then setting %PG_locked.
>> */
>> EXCLUSIVE,
>> /**
>> * @SHARED: Hold ref to page and check the bit when woken,
>> * like wait_on_page_writeback() waiting on %PG_writeback.
>> */
>> SHARED,
>> /**
>> * @DROP: Drop ref to page before wait, no check when woken,
>> * like put_and_wait_on_page_locked() on %PG_locked.
>> */
>> DROP,
>> };
>
>I'm with Matthew, I'd prefer not: the first looks a more readable,
>less cluttered comment to me than the second: this is just an arg
>to an internal helper in mm/filemap.c, itself not kernel-doc'ed.
Hmm, indeed, making this kernel-doc would be premature.
I was thinking about including this in a future description of the filemap internals, but until that would get written lot of things may change.
>But the comment is not there for me: if consensus is that the
>second is preferable, then sure, we can change it over.
>
>Hugh
--
Sincerely yours,
Mike.
Powered by blists - more mailing lists