lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite for Android: free password hash cracker in your pocket
[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Date:   Mon, 3 Dec 2018 10:03:26 +0000
From:   Valentin Schneider <valentin.schneider@....com>
To:     Peter Zijlstra <peterz@...radead.org>,
        Wen Yang <wen.yang99@....com.cn>
Cc:     Ingo Molnar <mingo@...hat.com>, linux-kernel@...r.kernel.org,
        zhong.weidong@....com.cn, Patrick Bellasi <Patrick.Bellasi@....com>
Subject: Re: [PATCH] sched/fair: Fix assignment of boolean variables

On 03/12/2018 08:33, Peter Zijlstra wrote:
> On Sat, Dec 01, 2018 at 05:09:36PM +0800, Wen Yang wrote:
>> Fix the following warnings reported by coccinelle:
>> kernel//sched/fair.c:7958:3-12: WARNING: Assignment of bool to 0/1
>>

Duh, Patrick raised that one to me last week but I got caught up in other
things. I realized I could keep the local 'overload' as bool in

    575638d1047e ("sched/core: Change root_domain->overload type to int")

but probably forgot to update 

    757ffdd705ee ("sched/fair: Set rq->rd->overload when misfit")

accordingly.

>> This also makes the code more readable.
> 
> I disagree; anybody that has trouble with 0/1 vs false/true needs to
> stay away from C.
> 
>> Signed-off-by: Wen Yang <wen.yang99@....com.cn>
>> CC: Ingo Molnar <mingo@...hat.com>
>> CC: Peter Zijlstra <peterz@...radead.org>
>> CC: linux-kernel@...r.kernel.org
>> ---
>>  kernel/sched/fair.c | 2 +-
>>  1 file changed, 1 insertion(+), 1 deletion(-)
>>
>> diff --git a/kernel/sched/fair.c b/kernel/sched/fair.c
>> index a2e8160968cb..f19aa66f9b15 100644
>> --- a/kernel/sched/fair.c
>> +++ b/kernel/sched/fair.c
>> @@ -7955,7 +7955,7 @@ static inline void update_sg_lb_stats(struct lb_env *env,
>>  		if (env->sd->flags & SD_ASYM_CPUCAPACITY &&
>>  		    sgs->group_misfit_task_load < rq->misfit_task_load) {
>>  			sgs->group_misfit_task_load = rq->misfit_task_load;
>> -			*overload = 1;
>> +			*overload = true;
>>  		}
>>  	}
>>  
> 
> Anyway, this code is going away anyway:
> 
>   https://lkml.kernel.org/r/20181119141857.8625-12-quentin.perret@arm.com
> 

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ