[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Message-ID: <20181206160645.GA4728@arm.com>
Date: Thu, 6 Dec 2018 16:06:45 +0000
From: Will Deacon <will.deacon@....com>
To: Steven Rostedt <rostedt@...dmis.org>
Cc: linux-kernel@...r.kernel.org, catalin.marinas@....com,
keescook@...omium.org, arnd@...db.de,
linux-arm-kernel@...ts.infradead.org,
Anders Roxell <anders.roxell@...aro.org>,
Ingo Molnar <mingo@...nel.org>
Subject: Re: [PATCH 2/2] arm64: ftrace: Set FTRACE_SCHEDULABLE before
ftrace_modify_all_code()
On Thu, Dec 06, 2018 at 10:59:14AM -0500, Steven Rostedt wrote:
> On Thu, 6 Dec 2018 13:20:07 +0000
> Will Deacon <will.deacon@....com> wrote:
>
> > On Wed, Dec 05, 2018 at 12:48:54PM -0500, Steven Rostedt wrote:
> > > From: "Steven Rostedt (VMware)" <rostedt@...dmis.org>
> > >
> > > It has been reported that ftrace_replace_code() which is called by
> > > ftrace_modify_all_code() can cause a soft lockup warning for an
> > > allmodconfig kernel. This is because all the debug options enabled
> > > causes the loop in ftrace_replace_code() (which loops over all the
> > > functions being enabled where there can be 10s of thousands), is too
> > > slow, and never schedules out.
> > >
> > > To solve this, setting FTRACE_SCHEDULABLE to the command passed into
> > > ftrace_replace_code() will make it call cond_resched() in the loop,
> > > which prevents the soft lockup warning from triggering.
> > >
> > > Link: http://lkml.kernel.org/r/20181204192903.8193-1-anders.roxell@linaro.org
> > >
> > > Reported-by: Anders Roxell <anders.roxell@...aro.org>
> > > Signed-off-by: Steven Rostedt (VMware) <rostedt@...dmis.org>
> > > ---
> > > arch/arm64/kernel/ftrace.c | 1 +
> > > 1 file changed, 1 insertion(+)
> > >
> > > diff --git a/arch/arm64/kernel/ftrace.c b/arch/arm64/kernel/ftrace.c
> > > index 57e962290df3..9a8de0a79f97 100644
> > > --- a/arch/arm64/kernel/ftrace.c
> > > +++ b/arch/arm64/kernel/ftrace.c
> > > @@ -193,6 +193,7 @@ int ftrace_make_nop(struct module *mod, struct dyn_ftrace *rec,
> > >
> > > void arch_ftrace_update_code(int command)
> > > {
> > > + command |= FTRACE_SCHEDULABLE;
> > > ftrace_modify_all_code(command);
> > > }
> >
> > Bikeshed: I'd probably go for FTRACE_MAY_SLEEP, but I'm not going to die
> > on that hill so...
>
> I like bike sheds. Hmm, it's not too late to change this. Perhaps I
> will.
>
> >
> > Acked-by: Will Deacon <will.deacon@....com>
>
> Thanks!
>
> If I decide to change the name to MAY_SLEEP, I assume I can still keep
> your Acked-by.
Of course!
Will
Powered by blists - more mailing lists