lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <20181213230045.2xgi2pyewkjbou22@treble>
Date:   Thu, 13 Dec 2018 17:00:45 -0600
From:   Josh Poimboeuf <jpoimboe@...hat.com>
To:     Petr Mladek <pmladek@...e.com>
Cc:     Jiri Kosina <jikos@...nel.org>, Miroslav Benes <mbenes@...e.cz>,
        Jason Baron <jbaron@...mai.com>,
        Joe Lawrence <joe.lawrence@...hat.com>,
        Evgenii Shatokhin <eshatokhin@...tuozzo.com>,
        live-patching@...r.kernel.org, linux-kernel@...r.kernel.org
Subject: Re: [PATCH v14 08/11] livepatch: Remove Nop structures when unused

On Thu, Nov 29, 2018 at 10:44:28AM +0100, Petr Mladek wrote:
> +static void __klp_free_funcs(struct klp_object *obj, bool free_all)
>  {
> -	struct klp_func *func;
> +	struct klp_func *func, *tmp_func;
> +
> +	klp_for_each_func_safe(obj, func, tmp_func) {
> +		if (!free_all && !func->nop)
> +			continue;

I suspect that changing 'free_all" to 'nops_only' (and inverting the
condition) would make the code more readable.

And a similar suggestion for __klp_free_objects().

> +
> +		/*
> +		 * Avoid double free. It would be tricky to wait for kobject
> +		 * callbacks when only NOPs are handled.
> +		 */
> +		list_del(&func->node);

I've read this comment several times but I still have no idea how it
relates to the code :-)

And a similar comment for __klp_free_objects().

-- 
Josh

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ