[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <1bfa8186371146e05bc0d84e308e0e08115236d5.camel@perches.com>
Date: Sun, 16 Dec 2018 09:47:23 -0800
From: Joe Perches <joe@...ches.com>
To: Amir Mahdi Ghorbanian <indigoomega021@...il.com>, marvin24@....de
Cc: devel@...verdev.osuosl.org, linux-kernel@...r.kernel.org,
gregkh@...uxfoundation.org, ac100@...ts.launchpad.net,
linux-tegra@...r.kernel.org
Subject: Re: [PATCH 2/2] Staging: nvec: nvec: fixed check style issues
On Sun, 2018-12-16 at 08:57 -0800, Amir Mahdi Ghorbanian wrote:
> Fixed an endline open parenthesis issue and replaced udelay() by the
> preferred usleep_range() function.
Not all checkpatch bleats need to be fixed.
Function names with 40+ character length identifiers makes
fitting within an 80 column limit nearly impossible.
> diff --git a/drivers/staging/nvec/nvec.c b/drivers/staging/nvec/nvec.c
[]
> @@ -382,8 +382,10 @@ static void nvec_request_master(struct work_struct *work)
> msg = list_first_entry(&nvec->tx_data, struct nvec_msg, node);
> spin_unlock_irqrestore(&nvec->tx_lock, flags);
> nvec_gpio_set_value(nvec, 0);
> - err = wait_for_completion_interruptible_timeout(
> - &nvec->ec_transfer, msecs_to_jiffies(5000));
> + done = &nvec->ec_transfer;
> + timeout = msecs_to_jiffies(5000);
> + err = wait_for_completion_interruptible_timeout(done,
> + timeout);
This was easier to read without the temporaries.
And where are done and timeout declared?
Please compile your patches before submitting them.
Powered by blists - more mailing lists