[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <CAKfTPtBokDKeaPOPNqxP_2CfzRRNdfZUmxDqsQ6puc+_FQRGbg@mail.gmail.com>
Date: Wed, 19 Dec 2018 16:25:08 +0100
From: Vincent Guittot <vincent.guittot@...aro.org>
To: Ulf Hansson <ulf.hansson@...aro.org>
Cc: Linux PM <linux-pm@...r.kernel.org>,
Linux Kernel Mailing List <linux-kernel@...r.kernel.org>,
"Rafael J. Wysocki" <rjw@...ysocki.net>,
Thara Gopinath <thara.gopinath@...aro.org>,
jani.nikula@...ux.intel.com,
Joonas Lahtinen <joonas.lahtinen@...ux.intel.com>,
rodrigo.vivi@...el.com, David Airlie <airlied@...ux.ie>,
"Intel graphics driver community testing & development"
<intel-gfx@...ts.freedesktop.org>,
dri-devel <dri-devel@...ts.freedesktop.org>
Subject: Re: [RFC v3 1/3] PM/runtime: Add a new interface to get accounted time
On Wed, 19 Dec 2018 at 10:58, Ulf Hansson <ulf.hansson@...aro.org> wrote:
>
> On Tue, 18 Dec 2018 at 15:55, Vincent Guittot
> <vincent.guittot@...aro.org> wrote:
> >
> > Some drivers (like i915/drm) need to get the accounted suspended time.
> > pm_runtime_accounted_time_get() will return the suspended or active
> > accounted time until now.
>
> I suggest to leave the active accounted time out for now. At least
> until we have some users.
>
> That said, perhaps rename the function to something along the lines
> of, pm_runtime_last_suspended_time(), to make it more clear.
>
> >
> > Signed-off-by: Vincent Guittot <vincent.guittot@...aro.org>
> > ---
> > drivers/base/power/runtime.c | 26 ++++++++++++++++++++++++++
> > include/linux/pm_runtime.h | 2 ++
> > 2 files changed, 28 insertions(+)
> >
> > diff --git a/drivers/base/power/runtime.c b/drivers/base/power/runtime.c
> > index 7062469..6461469 100644
> > --- a/drivers/base/power/runtime.c
> > +++ b/drivers/base/power/runtime.c
> > @@ -88,6 +88,32 @@ static void __update_runtime_status(struct device *dev, enum rpm_status status)
> > dev->power.runtime_status = status;
> > }
> >
> > +u64 pm_runtime_accounted_time_get(struct device *dev, enum rpm_status status, bool update)
> > +{
> > + u64 now = ktime_to_ns(ktime_get());
>
> I think you should stay on jiffies here - and then switch to ktime in patch 3.
I forgot to reply to this comment
Yes I agree that I should stay in jiffies there
>
> > + u64 delta = 0, time = 0;
> > + unsigned long flags;
> > +
> > + spin_lock_irqsave(&dev->power.lock, flags);
Powered by blists - more mailing lists