[<prev] [next>] [thread-next>] [day] [month] [year] [list]
Message-Id: <20181221072716.29017-1-andrew.smirnov@gmail.com>
Date: Thu, 20 Dec 2018 23:26:55 -0800
From: Andrey Smirnov <andrew.smirnov@...il.com>
To: linux-pci@...r.kernel.org
Cc: Andrey Smirnov <andrew.smirnov@...il.com>,
Lorenzo Pieralisi <lorenzo.pieralisi@....com>,
Bjorn Helgaas <bhelgaas@...gle.com>,
Fabio Estevam <fabio.estevam@....com>,
Chris Healy <cphealy@...il.com>,
Lucas Stach <l.stach@...gutronix.de>,
Leonard Crestez <leonard.crestez@....com>,
"A.s. Dong" <aisheng.dong@....com>,
Richard Zhu <hongxing.zhu@....com>, linux-imx@....com,
linux-arm-kernel@...ts.infradead.org, linux-kernel@...r.kernel.org
Subject: [PATCH 00/21] i.MX6, DesignWare PCI improvements
Everyone:
This is the series containing various small improvements that I made
while reading the code and researching commit history of pci-imx6.c
and pcie-designware*.c files. All changes are optional, so commits
that don't seem like an improvement can be easily dropped. Hopefully
each patch is self-explanatory.
I tested this series on i.MX6Q, i.MX7D and i.MX8MQ.
Feedback is welcome!
Thanks,
Andrey Smirnov
Andrey Smirnov (21):
PCI: imx6: Simplify imx7d_pcie_wait_for_phy_pll_lock()
PCI: imx6: Remove redundant debug tracing
PCI: imx6: Return -ETIMEOUT from imx6_pcie_wait_for_speed_change()
PCI: imx6: Remove duplicate macro definitions
PCI: imx6: Remove PCIE_PL_PFLR_* constants
PCI: imx6: Remove PCIE_PHY_RX_ASIC_OUT* constants
PCI: designware: Make use of IS_ALIGNED()
PCI: designware: Share code for dw_pcie_rd/wr_other_conf()
PCI: imx6: Drop imx6_pcie_link_up()
PCI: designware: imx6: Share PHY debug register definitions
PCI: designware: Make use of BIT() in constant definitions
PCI: imx6: Make use of BIT() in constant definitions
PCI: imx6: Simplify bit operations in PHY functions
PCI: imx6: Simplify pcie_phy_poll_ack()
PCI: imx6: Restrict PHY register data to 16-bit
PCI: imx6: Pass data to dw_pcie_writel_dbi() directly
PCI: imx6: Use common mask in imx6_pcie_reset_phy()
PCI: imx6: Simplify bit operations in imx6_setup_phy_mpll()
PCI: imx6: Remove magic numbers from imx6_pcie_establish_link()
PCI: designware: Make use of GENMASK/FIELD_PREP
PCI: designware: Remove superfluous shifting in definitions
drivers/pci/controller/dwc/pci-imx6.c | 151 +++++++-----------
.../pci/controller/dwc/pcie-designware-host.c | 61 +++----
drivers/pci/controller/dwc/pcie-designware.c | 18 +--
drivers/pci/controller/dwc/pcie-designware.h | 60 +++----
4 files changed, 116 insertions(+), 174 deletions(-)
--
2.19.1
Powered by blists - more mailing lists