lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite for Android: free password hash cracker in your pocket
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:   Fri, 4 Jan 2019 19:06:12 +0100
From:   Wolfram Sang <wsa@...-dreams.de>
To:     "Gustavo A. R. Silva" <gustavo@...eddedor.com>
Cc:     Wolfram Sang <wsa+renesas@...g-engineering.com>,
        Peter Rosin <peda@...ntia.se>, linux-i2c@...r.kernel.org,
        linux-kernel@...r.kernel.org
Subject: Re: [PATCH] i2c: mux: demux-pinctrl: use struct_size() in
 devm_kzalloc()


> Instead of leaving these open-coded and prone to type mistakes, we can
> now use the new struct_size() helper:

I am okay with this patch in general. However, I think the name of the
helper 'struct_size' is a bit unfortunate. I really wondered on the
first read why it needs 3 arguments to find out a struct size. I only
understood on the second read. I think 'trailing_array_struct_size'
would be way more clearer what it does.


Download attachment "signature.asc" of type "application/pgp-signature" (834 bytes)

Powered by blists - more mailing lists