[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Message-ID: <20190111100950.GA14142@vader>
Date: Fri, 11 Jan 2019 02:09:50 -0800
From: Omar Sandoval <osandov@...ndov.com>
To: Marcos Paulo de Souza <marcos.souza.org@...il.com>
Cc: linux-kernel@...r.kernel.org, Jens Axboe <axboe@...nel.dk>,
Tejun Heo <tj@...nel.org>, Josef Bacik <jbacik@...com>,
Mike Snitzer <snitzer@...hat.com>,
Michael Callahan <michaelcallahan@...com>,
Omar Sandoval <osandov@...com>,
Mikulas Patocka <mpatocka@...hat.com>,
Keith Busch <keith.busch@...el.com>,
Ming Lei <ming.lei@...hat.com>,
"Dennis Zhou (Facebook)" <dennisszhou@...il.com>
Subject: Re: [PATCH] blk_types.h: Use REQ_OP_WRITE in op_is_write
On Sat, Dec 22, 2018 at 08:03:54AM -0200, Marcos Paulo de Souza wrote:
> Instead of just using plain '1', as it improves readability.
>
> Signed-off-by: Marcos Paulo de Souza <marcos.souza.org@...il.com>
> ---
> include/linux/blk_types.h | 2 +-
> 1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/include/linux/blk_types.h b/include/linux/blk_types.h
> index 1dcf652ba0aa..905c666a0101 100644
> --- a/include/linux/blk_types.h
> +++ b/include/linux/blk_types.h
> @@ -377,7 +377,7 @@ static inline void bio_set_op_attrs(struct bio *bio, unsigned op,
>
> static inline bool op_is_write(unsigned int op)
> {
> - return (op & 1);
> + return (op & REQ_OP_WRITE);
> }
>
> /*
Nak. Conceptually, an operation is a write if the least significant bit
is set. The 1 here doesn't mean REQ_OP_WRITE, it means the least
significant bit.
Powered by blists - more mailing lists