[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-Id: <F652FEF1-0FD7-4FFD-80D4-44DBC2FF47B5@oracle.com>
Date: Tue, 15 Jan 2019 16:49:16 -0500
From: Chuck Lever <chuck.lever@...cle.com>
To: "Gustavo A. R. Silva" <gustavo@...eddedor.com>
Cc: Trond Myklebust <trond.myklebust@...merspace.com>,
Anna Schumaker <anna.schumaker@...app.com>,
Bruce Fields <bfields@...ldses.org>,
Jeff Layton <jlayton@...nel.org>,
"David S. Miller" <davem@...emloft.net>,
Linux NFS Mailing List <linux-nfs@...r.kernel.org>,
netdev@...r.kernel.org, linux-kernel@...r.kernel.org
Subject: Re: [PATCH net-next] svcrdma: Use struct_size() in kmalloc()
On Jan 15, 2019, at 4:11 PM, Gustavo A. R. Silva <gustavo@...eddedor.com> wrote:
> One of the more common cases of allocation size calculations is finding
> the size of a structure that has a zero-sized array at the end, along
> with memory for some number of elements for that array. For example:
>
> struct foo {
> int stuff;
> struct boo entry[];
> };
>
> instance = kmalloc(sizeof(struct foo) + count * sizeof(struct boo), GFP_KERNEL);
>
> Instead of leaving these open-coded and prone to type mistakes, we can
> now use the new struct_size() helper:
>
> instance = kmalloc(struct_size(instance, entry, count), GFP_KERNEL);
>
> This code was detected with the help of Coccinelle.
>
> Signed-off-by: Gustavo A. R. Silva <gustavo@...eddedor.com>
Reviewed-by: Chuck Lever <chuck.lever@...cle.com>
> ---
> net/sunrpc/xprtrdma/svc_rdma_rw.c | 3 +--
> 1 file changed, 1 insertion(+), 2 deletions(-)
>
> diff --git a/net/sunrpc/xprtrdma/svc_rdma_rw.c b/net/sunrpc/xprtrdma/svc_rdma_rw.c
> index dc1951759a8e..cad37c2122ab 100644
> --- a/net/sunrpc/xprtrdma/svc_rdma_rw.c
> +++ b/net/sunrpc/xprtrdma/svc_rdma_rw.c
> @@ -64,8 +64,7 @@ svc_rdma_get_rw_ctxt(struct svcxprt_rdma *rdma, unsigned int sges)
> spin_unlock(&rdma->sc_rw_ctxt_lock);
> } else {
> spin_unlock(&rdma->sc_rw_ctxt_lock);
> - ctxt = kmalloc(sizeof(*ctxt) +
> - SG_CHUNK_SIZE * sizeof(struct scatterlist),
> + ctxt = kmalloc(struct_size(ctxt, rw_first_sgl, SG_CHUNK_SIZE),
> GFP_KERNEL);
> if (!ctxt)
> goto out;
> --
> 2.20.1
--
Chuck Lever
Powered by blists - more mailing lists