[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <20190115185804.75e482c3@xps13>
Date: Tue, 15 Jan 2019 18:58:04 +0100
From: Miquel Raynal <miquel.raynal@...tlin.com>
To: "Gustavo A. R. Silva" <gustavo@...eddedor.com>
Cc: Boris Brezillon <bbrezillon@...nel.org>,
Richard Weinberger <richard@....at>,
David Woodhouse <dwmw2@...radead.org>,
Brian Norris <computersforpeace@...il.com>,
Marek Vasut <marek.vasut@...il.com>,
linux-mtd@...ts.infradead.org, linux-kernel@...r.kernel.org
Subject: Re: [PATCH] mtd: rawnand: marvell: use struct_size() in
devm_kzalloc()
Hi Gustavo,
"Gustavo A. R. Silva" <gustavo@...eddedor.com> wrote on Fri, 4 Jan 2019
12:20:51 -0600:
> One of the more common cases of allocation size calculations is finding
> the size of a structure that has a zero-sized array at the end, along
> with memory for some number of elements for that array. For example:
>
> struct foo {
> int stuff;
> void *entry[];
> };
>
> instance = devm_kzalloc(dev, sizeof(struct foo) + sizeof(void *) * count, GFP_KERNEL);
>
> Instead of leaving these open-coded and prone to type mistakes, we can
> now use the new struct_size() helper:
>
> instance = devm_kzalloc(dev, struct_size(instance, entry, count), GFP_KERNEL);
>
> This code was detected with the help of Coccinelle.
>
> Signed-off-by: Gustavo A. R. Silva <gustavo@...eddedor.com>
> ---
Applied to nand/next.
Thanks,
Miquèl
Powered by blists - more mailing lists