[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <47e2feac-3dbe-280d-0523-2226225a6733@linaro.org>
Date: Thu, 24 Jan 2019 10:54:32 +0200
From: Stanimir Varbanov <stanimir.varbanov@...aro.org>
To: Alexandre Courbot <acourbot@...omium.org>
Cc: Linux Media Mailing List <linux-media@...r.kernel.org>,
Mauro Carvalho Chehab <mchehab@...nel.org>,
Hans Verkuil <hverkuil@...all.nl>,
LKML <linux-kernel@...r.kernel.org>,
linux-arm-msm@...r.kernel.org,
Vikash Garodia <vgarodia@...eaurora.org>,
Tomasz Figa <tfiga@...omium.org>,
Malathi Gottam <mgottam@...eaurora.org>
Subject: Re: [PATCH 07/10] venus: helpers: add three more helper functions
Hi Alex,
Thanks for the review!
On 1/24/19 10:43 AM, Alexandre Courbot wrote:
> On Fri, Jan 18, 2019 at 1:21 AM Stanimir Varbanov
> <stanimir.varbanov@...aro.org> wrote:
>>
>> This adds three more helper functions:
>> * for internal buffers reallocation, applicable when we are doing
>> dynamic resolution change
>> * for initial buffer processing of capture and output queue buffer
>> types
>>
>> All of them will be needed for stateful Codec API support.
>>
>> Signed-off-by: Stanimir Varbanov <stanimir.varbanov@...aro.org>
>> ---
>> drivers/media/platform/qcom/venus/helpers.c | 82 +++++++++++++++++++++
>> drivers/media/platform/qcom/venus/helpers.h | 2 +
>> 2 files changed, 84 insertions(+)
>>
>> diff --git a/drivers/media/platform/qcom/venus/helpers.c b/drivers/media/platform/qcom/venus/helpers.c
>> index f33bbfea3576..637ce7b82d94 100644
>> --- a/drivers/media/platform/qcom/venus/helpers.c
>> +++ b/drivers/media/platform/qcom/venus/helpers.c
>> @@ -322,6 +322,52 @@ int venus_helper_intbufs_free(struct venus_inst *inst)
>> }
>> EXPORT_SYMBOL_GPL(venus_helper_intbufs_free);
>>
>> +int venus_helper_intbufs_realloc(struct venus_inst *inst)
>
> Does this function actually reallocate buffers? It seems to just free
> what we had previously.
The function free all internal buffers except PERSIST. After that the
buffers are allocated in intbufs_set_buffer function (I know that the
function name is misleading).
>
>
>> +{
>> + enum hfi_version ver = inst->core->res->hfi_version;
>> + struct hfi_buffer_desc bd;
>> + struct intbuf *buf, *n;
>> + int ret;
>> +
>> + list_for_each_entry_safe(buf, n, &inst->internalbufs, list) {
>> + if (buf->type == HFI_BUFFER_INTERNAL_PERSIST ||
>> + buf->type == HFI_BUFFER_INTERNAL_PERSIST_1)
>> + continue;
>> +
>> + memset(&bd, 0, sizeof(bd));
>> + bd.buffer_size = buf->size;
>> + bd.buffer_type = buf->type;
>> + bd.num_buffers = 1;
>> + bd.device_addr = buf->da;
>> + bd.response_required = true;
>> +
>> + ret = hfi_session_unset_buffers(inst, &bd);
>> +
>> + dma_free_attrs(inst->core->dev, buf->size, buf->va, buf->da,
>> + buf->attrs);
>> +
>> + list_del_init(&buf->list);
>> + kfree(buf);
>> + }
>> +
>> + ret = intbufs_set_buffer(inst, HFI_BUFFER_INTERNAL_SCRATCH(ver));
>> + if (ret)
>> + goto err;
>> +
>> + ret = intbufs_set_buffer(inst, HFI_BUFFER_INTERNAL_SCRATCH_1(ver));
>> + if (ret)
>> + goto err;
>> +
>> + ret = intbufs_set_buffer(inst, HFI_BUFFER_INTERNAL_SCRATCH_2(ver));
>> + if (ret)
>> + goto err;
>> +
>> + return 0;
>> +err:
>> + return ret;
>> +}
>> +EXPORT_SYMBOL_GPL(venus_helper_intbufs_realloc);
>> +
--
regards,
Stan
Powered by blists - more mailing lists