[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <20190128194943.GA18515@redhat.com>
Date: Mon, 28 Jan 2019 14:49:43 -0500
From: Joe Lawrence <joe.lawrence@...hat.com>
To: Alice Ferrazzi <alicef@...cef.me>
Cc: jpoimboe@...hat.com, jeyu@...nel.org, jikos@...nel.org,
mbenes@...e.cz, pmladek@...e.com, live-patching@...r.kernel.org,
linux-kernel@...r.kernel.org,
Alice Ferrazzi <alice.ferrazzi@...aclelinux.com>
Subject: Re: [PATCH] livepatch: core: Return ENOTSUPP instead of ENOSYS
On Sun, Jan 27, 2019 at 04:26:30AM +0900, Alice Ferrazzi wrote:
> This patch fixes a checkpatch warning:
> WARNING: ENOSYS means 'invalid syscall nr' and nothing else
>
> Signed-off-by: Alice Ferrazzi <alice.ferrazzi@...aclelinux.com>
> ---
> kernel/livepatch/core.c | 2 +-
> 1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/kernel/livepatch/core.c b/kernel/livepatch/core.c
> index 5b77a7314e01..eea6b94fef89 100644
> --- a/kernel/livepatch/core.c
> +++ b/kernel/livepatch/core.c
> @@ -897,7 +897,7 @@ int klp_register_patch(struct klp_patch *patch)
>
> if (!klp_have_reliable_stack()) {
> pr_err("This architecture doesn't have support for the livepatch consistency model.\n");
> - return -ENOSYS;
> + return -ENOTSUPP;
> }
>
> return klp_init_patch(patch);
> --
> 2.19.2
>
Hi Alice,
Patches should be based off the upstream livepatching tree, found here:
git://git.kernel.org/pub/scm/linux/kernel/git/livepatching/livepatching.git
and in this case, the for-next branch, which holds patches that have
already been queued up for the next release. This one:
958ef1e39d24 ("livepatch: Simplify API by removing registration step")
has moved the code in question from klp_register_patch() to
klp_enable_patch().
As far as the change itself, I don't have strong opinion about it
either way.
On the one hand, there is the checkpatch warning and -ENOTSUPP reads
more intuitively than -ENOSYS.
However, the current pattern seems to be more prevelent in the kernel.
I wonder if the checkpatch warning would be better specified for return
values that are actually passed back to userspace.
Also, klp_register_patch(), now klp_enable_patch(), is exported for
module use, though I don't believe anyone (samples / tests / kpatch /
kgraft?) is inspecting which error value is returned.
I would defer to whichever convention the maintainers prefer here.
-- Joe
Powered by blists - more mailing lists