[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <20190128132634.GB744@infradead.org>
Date: Mon, 28 Jan 2019 05:26:34 -0800
From: Christoph Hellwig <hch@...radead.org>
To: Thomas Bogendoerfer <tbogendoerfer@...e.de>
Cc: Bjorn Helgaas <bhelgaas@...gle.com>,
James Hogan <jhogan@...nel.org>, linux-kernel@...r.kernel.org,
linux-mips@...r.kernel.org, linux-pci@...r.kernel.org,
Lorenzo Pieralisi <lorenzo.pieralisi@....com>,
Paul Burton <paul.burton@...s.com>,
Ralf Baechle <ralf@...ux-mips.org>
Subject: Re: [PATCH 5/7] MIPS: SGI-IP27: rework HUB interrupts
> struct slice_data {
> unsigned long irq_enable_mask[2];
> - int level_to_irq[LEVELS_PER_SLICE];
> };
Any reaason to keep struct slice_data around at all?
> + HUB_S(hd->irq_mask_addr[0], si->irq_enable_mask[0]);
> + HUB_S(hd->irq_mask_addr[1], si->irq_enable_mask[1]);
I know the HUB_S name is pre-existing, but maybe you can throw in
a patch to give it a more descriptive name? Or maybe just kill
it off entirely at least for new code and use __raw_readq
directly.
> #endif
> {
> - /* "map" swlevel to irq */
> - struct slice_data *si = cpu_data[cpu].data;
> -
> - irq = si->level_to_irq[swlevel];
> - do_IRQ(irq);
> + do_IRQ(swlevel + IP27_HUB_IRQ_BASE);
> }
Looks like we can just kill the { } and additional indentation here.
Powered by blists - more mailing lists