[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <632671842.3079.1548781059601.JavaMail.zimbra@efficios.com>
Date: Tue, 29 Jan 2019 11:57:39 -0500 (EST)
From: Mathieu Desnoyers <mathieu.desnoyers@...icios.com>
To: carlos <carlos@...hat.com>, Florian Weimer <fweimer@...hat.com>
Cc: Joseph Myers <joseph@...esourcery.com>,
Szabolcs Nagy <szabolcs.nagy@....com>,
libc-alpha <libc-alpha@...rceware.org>,
Thomas Gleixner <tglx@...utronix.de>,
Ben Maurer <bmaurer@...com>,
Peter Zijlstra <peterz@...radead.org>,
"Paul E. McKenney" <paulmck@...ux.vnet.ibm.com>,
Boqun Feng <boqun.feng@...il.com>,
Will Deacon <will.deacon@....com>,
Dave Watson <davejwatson@...com>, Paul Turner <pjt@...gle.com>,
Rich Felker <dalias@...c.org>,
linux-kernel <linux-kernel@...r.kernel.org>,
linux-api <linux-api@...r.kernel.org>
Subject: Re: [RFC PATCH glibc 1/4] glibc: Perform rseq(2) registration at C
startup and thread creation (v6)
----- On Jan 21, 2019, at 4:35 PM, Mathieu Desnoyers mathieu.desnoyers@...icios.com wrote:
[...]
> diff --git a/sysdeps/unix/sysv/linux/sys/rseq.h
> b/sysdeps/unix/sysv/linux/sys/rseq.h
> new file mode 100644
> index 0000000000..61937fb193
> --- /dev/null
> +++ b/sysdeps/unix/sysv/linux/sys/rseq.h
> @@ -0,0 +1,64 @@
[...]
> +
> +#ifndef _SYS_RSEQ_H
> +#define _SYS_RSEQ_H 1
> +
> +/* We use the structures declarations from the kernel headers. */
> +#include <linux/rseq.h>
> +#include <stdint.h>
> +
> +/* Signature required before each abort handler code. */
> +#define RSEQ_SIG 0x53053053
I recalled that aarch64 defines RSEQ_SIG to a different value which maps to
a valid trap instruction. So I plan to move the RSEQ_SIG define to per-arch
headers like this:
sysdeps/unix/sysv/linux/aarch64/bits/rseq.h | 24 ++
sysdeps/unix/sysv/linux/arm/bits/rseq.h | 24 ++
sysdeps/unix/sysv/linux/bits/rseq.h | 23 ++
sysdeps/unix/sysv/linux/mips/bits/rseq.h | 24 ++
sysdeps/unix/sysv/linux/powerpc/bits/rseq.h | 24 ++
sysdeps/unix/sysv/linux/s390/bits/rseq.h | 24 ++
sysdeps/unix/sysv/linux/x86/bits/rseq.h | 24 ++
where "bits/rseq.h" contains a #error:
# error "Architecture does not define RSEQ_SIG.
sys/rseq.h will now include <bits/rseq.h>.
> +
> +enum rseq_register_state
> +{
> + /* Value RSEQ_REGISTER_ALLOWED means it is allowed to update
> + the refcount field and to register/unregister rseq. */
> + RSEQ_REGISTER_ALLOWED = 0,
> + /* Value RSEQ_REGISTER_NESTED means it is temporarily forbidden
> + to update the refcount field or to register/unregister rseq. */
> + RSEQ_REGISTER_NESTED = 1,
I plan to rename "RSEQ_REGISTER_NESTED" to "RSEQ_REGISTER_ONGOING" which
seems to better represent the current registration state.
Please let me know if anything is wrong with those changes.
Thanks,
Mathieu
> + /* Value RSEQ_REGISTER_EXITING means it is forbidden to update the
> + refcount field or to register/unregister rseq for the rest of the
> + thread's lifetime. */
> + RSEQ_REGISTER_EXITING = 2,
> +};
--
Mathieu Desnoyers
EfficiOS Inc.
http://www.efficios.com
Powered by blists - more mailing lists