lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:   Tue, 29 Jan 2019 11:22:54 -0600
From:   "Gustavo A. R. Silva" <gustavo@...eddedor.com>
To:     Song Liu <liu.song.a23@...il.com>
Cc:     Shaohua Li <shli@...nel.org>, linux-raid@...r.kernel.org,
        open list <linux-kernel@...r.kernel.org>
Subject: Re: [PATCH] md-linear: use struct_size() in kzalloc()

Hi all,

Friendly ping:

Who can take this?

Thanks
--
Gustavo

On 1/7/19 5:01 PM, Song Liu wrote:
> On Mon, Jan 7, 2019 at 10:35 AM Gustavo A. R. Silva
> <gustavo@...eddedor.com> wrote:
>>
>> One of the more common cases of allocation size calculations is finding the
>> size of a structure that has a zero-sized array at the end, along with memory
>> for some number of elements for that array. For example:
>>
>> struct foo {
>>     int stuff;
>>     void *entry[];
>> };
>>
>> instance = kzalloc(sizeof(struct foo) + sizeof(void *) * count, GFP_KERNEL);
>>
>> Instead of leaving these open-coded and prone to type mistakes, we can now
>> use the new struct_size() helper:
>>
>> instance = kzalloc(struct_size(instance, entry, count), GFP_KERNEL);
>>
>> This code was detected with the help of Coccinelle.
>>
>> Signed-off-by: Gustavo A. R. Silva <gustavo@...eddedor.com>
> 
> Acked-by: Song Liu <songliubraving@...com>
> 
>> ---
>>  drivers/md/md-linear.c | 3 +--
>>  1 file changed, 1 insertion(+), 2 deletions(-)
>>
>> diff --git a/drivers/md/md-linear.c b/drivers/md/md-linear.c
>> index d45c697c0ebe..5998d78aa189 100644
>> --- a/drivers/md/md-linear.c
>> +++ b/drivers/md/md-linear.c
>> @@ -96,8 +96,7 @@ static struct linear_conf *linear_conf(struct mddev *mddev, int raid_disks)
>>         int i, cnt;
>>         bool discard_supported = false;
>>
>> -       conf = kzalloc (sizeof (*conf) + raid_disks*sizeof(struct dev_info),
>> -                       GFP_KERNEL);
>> +       conf = kzalloc(struct_size(conf, disks, raid_disks), GFP_KERNEL);
>>         if (!conf)
>>                 return NULL;
>>
>> --
>> 2.20.1
>>

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ