[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Message-Id: <20190201120608.2BE8760987@smtp.codeaurora.org>
Date: Fri, 1 Feb 2019 12:06:08 +0000 (UTC)
From: Kalle Valo <kvalo@...eaurora.org>
To: "Gustavo A. R. Silva" <gustavo@...eddedor.com>
Cc: Igor Mitsyanko <imitsyanko@...ntenna.com>,
Avinash Patil <avinashp@...ntenna.com>,
Sergey Matyukevich <smatyukevich@...ntenna.com>,
"David S. Miller" <davem@...emloft.net>,
linux-wireless@...r.kernel.org, netdev@...r.kernel.org,
linux-kernel@...r.kernel.org,
"Gustavo A. R. Silva" <gustavo@...eddedor.com>
Subject: Re: [PATCH] qtnfmac: use struct_size() in kzalloc()
"Gustavo A. R. Silva" <gustavo@...eddedor.com> wrote:
> One of the more common cases of allocation size calculations is finding the
> size of a structure that has a zero-sized array at the end, along with memory
> for some number of elements for that array. For example:
>
> struct foo {
> int stuff;
> void *entry[];
> };
>
> instance = kzalloc(sizeof(struct foo) + sizeof(void *) * count, GFP_KERNEL);
>
> Instead of leaving these open-coded and prone to type mistakes, we can now
> use the new struct_size() helper:
>
> instance = kzalloc(struct_size(instance, entry, count), GFP_KERNEL);
>
> This code was detected with the help of Coccinelle.
>
> Signed-off-by: Gustavo A. R. Silva <gustavo@...eddedor.com>
> Reviewed-by: Sergey Matyukevich <sergey.matyukevich.os@...ntenna.com>
Patch applied to wireless-drivers-next.git, thanks.
db040dfa53e2 qtnfmac: use struct_size() in kzalloc()
--
https://patchwork.kernel.org/patch/10752601/
https://wireless.wiki.kernel.org/en/developers/documentation/submittingpatches
Powered by blists - more mailing lists