[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <20190205114616.GQ17528@hirez.programming.kicks-ass.net>
Date: Tue, 5 Feb 2019 12:46:16 +0100
From: Peter Zijlstra <peterz@...radead.org>
To: kan.liang@...ux.intel.com
Cc: x86@...nel.org, linux-kernel@...r.kernel.org, tglx@...utronix.de,
bp@...en8.de, mingo@...hat.com, ak@...ux.intel.com,
eranian@...gle.com
Subject: Re: [PATCH V7 1/5] x86/cpufeature: Add facility to check for min
microcode revisions
On Mon, Feb 04, 2019 at 02:23:29PM -0800, kan.liang@...ux.intel.com wrote:
> extern const struct x86_cpu_id *x86_match_cpu(const struct x86_cpu_id *match);
>
> +/*
> + * Match specific microcode revisions.
> + *
> + * vendor/family/model/stepping must be all set.
> + *
> + * only checks against the boot CPU. When mixed-stepping configs are
> + * valid for a CPU model, add a quirk for every valid stepping and
> + * do the fine-tuning in the quirk handler.
> + */
> +
> +struct x86_cpu_desc {
> + __u8 x86; /* CPU family */
> + __u8 x86_vendor; /* CPU vendor */
So Boris asked me to remove the tail comments (done), but what about I
do: % s/\<x86\>/&_family/g, on the rest of this too? I know we have
cpuinfo_x86::x86 history, but at some point we should rename that too.
> + __u8 x86_model;
> + __u8 x86_stepping;
> + __u32 x86_microcode_rev;
> +};
Powered by blists - more mailing lists