[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Message-ID: <52981343-fef4-50a5-4d82-a85c7727e915@embeddedor.com>
Date: Thu, 7 Feb 2019 17:02:27 -0600
From: "Gustavo A. R. Silva" <gustavo@...eddedor.com>
To: Eric Anholt <eric@...olt.net>, David Airlie <airlied@...ux.ie>,
Daniel Vetter <daniel@...ll.ch>
Cc: dri-devel@...ts.freedesktop.org, linux-kernel@...r.kernel.org
Subject: Re: [PATCH] drm/vc4: Use struct_size() in kzalloc()
On 2/7/19 4:59 PM, Eric Anholt wrote:
> "Gustavo A. R. Silva" <gustavo@...eddedor.com> writes:
>
>> One of the more common cases of allocation size calculations is finding
>> the size of a structure that has a zero-sized array at the end, along
>> with memory for some number of elements for that array. For example:
>>
>> struct foo {
>> int stuff;
>> void *entry[];
>> };
>>
>> instance = kzalloc(sizeof(struct foo) + count * sizeof(struct boo), GFP_KERNEL);
>>
>> Instead of leaving these open-coded and prone to type mistakes, we can
>> now use the new struct_size() helper:
>>
>> instance = kzalloc(struct_size(instance, entry, count), GFP_KERNEL);
>>
>> This code was detected with the help of Coccinelle.
>>
>> Signed-off-by: Gustavo A. R. Silva <gustavo@...eddedor.com>
>
> Reviewed and pushed to drm-misc-next. Thanks!
>
Thank you, Eric.
--
Gustavo
Powered by blists - more mailing lists