lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <20190207140819.GF2414@zn.tnic>
Date:   Thu, 7 Feb 2019 15:08:19 +0100
From:   Borislav Petkov <bp@...en8.de>
To:     Daniel Bristot de Oliveira <bristot@...hat.com>
Cc:     linux-kernel@...r.kernel.org, Thomas Gleixner <tglx@...utronix.de>,
        Ingo Molnar <mingo@...hat.com>,
        "H. Peter Anvin" <hpa@...or.com>,
        Greg Kroah-Hartman <gregkh@...uxfoundation.org>,
        Masami Hiramatsu <mhiramat@...nel.org>,
        "Steven Rostedt (VMware)" <rostedt@...dmis.org>,
        Jiri Kosina <jkosina@...e.cz>,
        Josh Poimboeuf <jpoimboe@...hat.com>,
        "Peter Zijlstra (Intel)" <peterz@...radead.org>,
        Chris von Recklinghausen <crecklin@...hat.com>,
        Jason Baron <jbaron@...mai.com>, Scott Wood <swood@...hat.com>,
        Marcelo Tosatti <mtosatti@...hat.com>,
        Clark Williams <williams@...hat.com>, x86@...nel.org
Subject: Re: [PATCH V4 2/9] jump_label: Add the jump_label_can_update_check()
 helper

On Thu, Feb 07, 2019 at 02:21:09PM +0100, Daniel Bristot de Oliveira wrote:
> diff --git a/kernel/jump_label.c b/kernel/jump_label.c
> index 288d630da22d..1e6f4d27e28d 100644
> --- a/kernel/jump_label.c
> +++ b/kernel/jump_label.c
> @@ -374,22 +374,29 @@ static enum jump_label_type jump_label_type(struct jump_entry *entry)
>  	return enabled ^ branch;
>  }
>  
> +static bool jump_label_can_update(struct jump_entry *entry, bool init)
> +{
> +	/*
> +	 * Cannot update code that was in an init text area.
> +	 */
> +	if (!init || jump_entry_is_init(entry))

Shouldn't this be &&

?

> +		return false;
> +
> +	if (WARN_ONCE(!kernel_text_address(jump_entry_code(entry)),
> +			 "can't patch jump_label at %pS", (void *)jump_entry_code(entry)))
> +		return false;

Yeah, I think that this way of writing it is less readable than:

	if (!kernel_text_address(jump_entry_code(entry))) {
		WARN_ONCE(1, "can't patch jump_label at %pS", (void *)jump_entry_code(entry));
		return false;
	}

> +		if (jump_label_can_update(entry, init)) {
> +			arch_jump_label_transform(entry, jump_label_type(entry));

Yap.

Thx.

-- 
Regards/Gruss,
    Boris.

Good mailing practices for 400: avoid top-posting and trim the reply.

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ