lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Message-Id: <20190208100401.GB11096@rapoport-lnx>
Date:   Fri, 8 Feb 2019 12:04:01 +0200
From:   Mike Rapoport <rppt@...ux.ibm.com>
To:     Souptick Joarder <jrdr.linux@...il.com>
Cc:     Andrew Morton <akpm@...ux-foundation.org>,
        Michal Hocko <mhocko@...e.com>, Linux-MM <linux-mm@...ck.org>,
        linux-kernel@...r.kernel.org
Subject: Re: [PATCH 1/2] memblock: remove memblock_{set,clear}_region_flags

On Thu, Feb 07, 2019 at 10:02:24PM +0530, Souptick Joarder wrote:
> On Wed, Feb 6, 2019 at 6:01 PM Mike Rapoport <rppt@...ux.ibm.com> wrote:
> >
> > The memblock API provides dedicated helpers to set or clear a flag on a
> > memory region, e.g. memblock_{mark,clear}_hotplug().
> >
> > The memblock_{set,clear}_region_flags() functions are used only by the
> > memblock internal function that adjusts the region flags.
> > Drop these functions and use open-coded implementation instead.
> >
> > Signed-off-by: Mike Rapoport <rppt@...ux.ibm.com>
> > ---
> >  include/linux/memblock.h | 12 ------------
> >  mm/memblock.c            |  9 ++++++---
> >  2 files changed, 6 insertions(+), 15 deletions(-)
> >
> > diff --git a/include/linux/memblock.h b/include/linux/memblock.h
> > index 71c9e32..32a9a6b 100644
> > --- a/include/linux/memblock.h
> > +++ b/include/linux/memblock.h
> > @@ -317,18 +317,6 @@ void __next_mem_pfn_range_in_zone(u64 *idx, struct zone *zone,
> >         for_each_mem_range_rev(i, &memblock.memory, &memblock.reserved, \
> >                                nid, flags, p_start, p_end, p_nid)
> >
> > -static inline void memblock_set_region_flags(struct memblock_region *r,
> > -                                            enum memblock_flags flags)
> > -{
> > -       r->flags |= flags;
> > -}
> > -
> > -static inline void memblock_clear_region_flags(struct memblock_region *r,
> > -                                              enum memblock_flags flags)
> > -{
> > -       r->flags &= ~flags;
> > -}
> > -
> >  #ifdef CONFIG_HAVE_MEMBLOCK_NODE_MAP
> >  int memblock_set_node(phys_addr_t base, phys_addr_t size,
> >                       struct memblock_type *type, int nid);
> > diff --git a/mm/memblock.c b/mm/memblock.c
> > index 0151a5b..af5fe8e 100644
> > --- a/mm/memblock.c
> > +++ b/mm/memblock.c
> > @@ -851,11 +851,14 @@ static int __init_memblock memblock_setclr_flag(phys_addr_t base,
> >         if (ret)
> >                 return ret;
> >
> > -       for (i = start_rgn; i < end_rgn; i++)
> > +       for (i = start_rgn; i < end_rgn; i++) {
> > +               struct memblock_region *r = &type->regions[i];
> 
> Is it fine if we drop this memblock_region *r altogether ?

I prefer using a local variable to

	type->regions[i].flags
 
> > +
> >                 if (set)
> > -                       memblock_set_region_flags(&type->regions[i], flag);
> > +                       r->flags |= flag;
> >                 else
> > -                       memblock_clear_region_flags(&type->regions[i], flag);
> > +                       r->flags &= ~flag;
> > +       }
> >
> >         memblock_merge_regions(type);
> >         return 0;
> > --
> > 2.7.4
> >
> 

-- 
Sincerely yours,
Mike.

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ