lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:   Wed, 13 Feb 2019 11:16:53 -0500
From:   Waiman Long <longman@...hat.com>
To:     Peter Zijlstra <peterz@...radead.org>
Cc:     Ingo Molnar <mingo@...hat.com>, Will Deacon <will.deacon@....com>,
        Thomas Gleixner <tglx@...utronix.de>,
        linux-kernel@...r.kernel.org, x86@...nel.org,
        Arnd Bergmann <arnd@...db.de>, Borislav Petkov <bp@...en8.de>,
        "H. Peter Anvin" <hpa@...or.com>,
        Davidlohr Bueso <dave@...olabs.net>,
        Linus Torvalds <torvalds@...ux-foundation.org>,
        Andrew Morton <akpm@...ux-foundation.org>,
        Tim Chen <tim.c.chen@...ux.intel.com>
Subject: Re: [PATCH 03/10] locking/rwsem: Rename kernel/locking/rwsem.h

On 02/13/2019 10:54 AM, Peter Zijlstra wrote:
> On Wed, Feb 13, 2019 at 10:47:11AM -0500, Waiman Long wrote:
>> On 02/13/2019 04:19 AM, Peter Zijlstra wrote:
>>> On Tue, Feb 12, 2019 at 07:27:00PM -0500, Waiman Long wrote:
>>>> The content of kernel/locking/rwsem.h is now specific to rwsem-xadd only.
>>>> Rename it to rwsem-xadd.h to indicate that it is specific to rwsem-xadd
>>>> and include it only when CONFIG_RWSEM_XCHGADD_ALGORITHM is set. As a result,
>>>> the CONFIG_RWSEM_XCHGADD_ALGORITHM conditional compilation directives can
>>>> be removed. There is no functional change.
>>> Since all of rwsem-xadd is now generic code; how about we delete the
>>> spinlock thing and keep everything rwsem ?
>>>
>>> We don't carry a special spinlock mutex implementation either. And
>>> arguably any arch that uses spinlock based atomics (afaict the only case
>>> where rwsem-spinlock makes any sense anyway) suck anyway.
>> I don't mind removing the rwsem-spinlock code and have just one
>> implementation for all as long as there is no objection from others. I
>> don't know the history of why we have 2 implementations of rwsem and so
>> I didn't plan to do that.
> It is from before my time too; but I think rwsem-spinlock is generic and
> didn't require arch asm helpers, where rwsem-xadd did, but we just fixed
> that :-)

OK, I will attempt to send a patch to remove rwsem-spinlock. That will
touch a lot of arch specific files too.

Cheers,
Longman

Powered by blists - more mailing lists