[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <20190215093503.GH2326@kadam>
Date: Fri, 15 Feb 2019 12:35:03 +0300
From: Dan Carpenter <dan.carpenter@...cle.com>
To: Chao Yu <yuchao0@...wei.com>
Cc: devel@...verdev.osuosl.org,
Greg Kroah-Hartman <gregkh@...uxfoundation.org>,
Miao Xie <miaoxie@...wei.com>, Chao Yu <chao@...nel.org>,
LKML <linux-kernel@...r.kernel.org>, stable@...r.kernel.org,
weidu.du@...wei.com, Al Viro <viro@...IV.linux.org.uk>,
linux-erofs@...ts.ozlabs.org, Fang Wei <fangwei1@...wei.com>
Subject: Re: [PATCH v2] staging: erofs: keep corrupted fs from crashing
kernel in erofs_namei()
On Fri, Feb 15, 2019 at 05:32:33PM +0800, Chao Yu wrote:
> On 2019/2/15 15:57, Dan Carpenter wrote:
> > On Fri, Feb 15, 2019 at 03:02:25PM +0800, Chao Yu wrote:
> >> On 2019/2/1 20:16, Gao Xiang wrote:
> >>> + /*
> >>> + * on-disk error, let's only BUG_ON in the debugging mode.
> >>> + * otherwise, it will return 1 to just skip the invalid name
> >>> + * and go on (in consideration of the lookup performance).
> >>> + */
> >>> + DBG_BUGON(qd->name > qd->end);
> >>
> >> qd->name == qd->end is not allowed as well?
> >>
> >> So will it be better to return directly here?
> >>
> >> if (unlikely(qd->name >= qd->end)) {
> >> DBG_BUGON(1);
> >> return 1;
> >> }
> >
> > Please don't add likely/unlikely() annotations unless you have
> > benchmarked it and it makes a difference.
>
> Well, it only occur for corrupted image, since the image is readonly, so it
> is really rare.
The likely/unlikely() annotations make the code harder to read. It's
only worth it if it's is a speedup on a fast path.
regards,
dan carpenter
Powered by blists - more mailing lists