lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Date:   Thu, 21 Feb 2019 01:00:52 +0900
From:   Masami Hiramatsu <mhiramat@...nel.org>
To:     Jann Horn <jannh@...gle.com>
Cc:     Ingo Molnar <mingo@...nel.org>,
        Steven Rostedt <rostedt@...dmis.org>,
        kernel list <linux-kernel@...r.kernel.org>,
        Song Liu <songliubraving@...com>
Subject: Re: [PATCH] perf/core: use strndup_user() instead of buggy
 open-coded version

Hi Jann,

On Wed, 20 Feb 2019 16:19:10 +0100
Jann Horn <jannh@...gle.com> wrote:

> On Tue, Feb 19, 2019 at 3:51 PM Masami Hiramatsu <mhiramat@...nel.org> wrote:
> > On Tue, 19 Feb 2019 20:45:02 +0900
> > Masami Hiramatsu <mhiramat@...nel.org> wrote:
> >
> > > On Mon, 18 Feb 2019 23:07:23 +0100
> > > Jann Horn <jannh@...gle.com> wrote:
> > >
> > > > The first version of this method was missing the check for
> > > > `ret == PATH_MAX`; then such a check was added, but it didn't call kfree()
> > > > on error, so there was still a small memory leak in the error case.
> > > > Fix it by using strndup_user() instead of open-coding it.
> > > >
> > >
> > > This looks good to me.
> > >
> > > Reviewed-by: Masami Hiramatsu <mhiramat@...nel.org>
> >
> > BTW, I think it should note that if the string is longer than PATH_MAX.
> > caller will receive -EINVAL instead of -E2BIG with this fix.
> 
> Oh, whoops, I hadn't noticed that.
> 
> Do you want me to just add a note to the changelog, or do I have to
> work around this in the code?

I think work around will be good if this goes to stable, since I guess
this return code may go to user space.

Thank you,

> 
> > > > Fixes: 0eadcc7a7bc0 ("perf/core: Fix perf_uprobe_init()")
> > > > Signed-off-by: Jann Horn <jannh@...gle.com>
> > > > ---
> > > > compile-tested only
> > > >
> > > >  kernel/trace/trace_event_perf.c | 14 +++++---------
> > > >  1 file changed, 5 insertions(+), 9 deletions(-)
> > > >
> > > > diff --git a/kernel/trace/trace_event_perf.c b/kernel/trace/trace_event_perf.c
> > > > index 76217bbef815..c744b02081c3 100644
> > > > --- a/kernel/trace/trace_event_perf.c
> > > > +++ b/kernel/trace/trace_event_perf.c
> > > > @@ -299,15 +299,11 @@ int perf_uprobe_init(struct perf_event *p_event,
> > > >
> > > >     if (!p_event->attr.uprobe_path)
> > > >             return -EINVAL;
> > > > -   path = kzalloc(PATH_MAX, GFP_KERNEL);
> > > > -   if (!path)
> > > > -           return -ENOMEM;
> > > > -   ret = strncpy_from_user(
> > > > -           path, u64_to_user_ptr(p_event->attr.uprobe_path), PATH_MAX);
> > > > -   if (ret == PATH_MAX)
> > > > -           return -E2BIG;
> > > > -   if (ret < 0)
> > > > -           goto out;
> > > > +
> > > > +   path = strndup_user(u64_to_user_ptr(p_event->attr.uprobe_path),
> > > > +                       PATH_MAX);
> > > > +   if (IS_ERR(path))
> > > > +           return PTR_ERR(path);
> > > >     if (path[0] == '\0') {
> > > >             ret = -EINVAL;
> > > >             goto out;


-- 
Masami Hiramatsu <mhiramat@...nel.org>

Powered by blists - more mailing lists