[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <20190304113519.2e102b25@xps13>
Date: Mon, 4 Mar 2019 11:35:19 +0100
From: Miquel Raynal <miquel.raynal@...tlin.com>
To: Paul Cercueil <paul@...pouillou.net>
Cc: David Woodhouse <dwmw2@...radead.org>,
Brian Norris <computersforpeace@...il.com>,
Boris Brezillon <bbrezillon@...nel.org>,
Marek Vasut <marek.vasut@...il.com>,
Richard Weinberger <richard@....at>,
Rob Herring <robh+dt@...nel.org>,
Mark Rutland <mark.rutland@....com>,
Harvey Hunt <harveyhuntnexus@...il.com>,
linux-mtd@...ts.infradead.org, devicetree@...r.kernel.org,
linux-kernel@...r.kernel.org
Subject: Re: [PATCH v4 8/9] mtd: rawnand: ingenic: Add support for the
JZ4725B
Hi Paul,
Paul Cercueil <paul@...pouillou.net> wrote on Sat, 9 Feb 2019 16:23:04
-0300:
> The boot ROM of the JZ4725B SoC expects a specific OOB layout on the
> NAND, so we use it unconditionally in the ingenic-nand driver.
>
> Also add the jz4725b-bch driver to support the JZ4725B-specific BCH
> hardware.
>
> Signed-off-by: Paul Cercueil <paul@...pouillou.net>
> ---
>
> Changes:
>
> v2: Instead of forcing the OOB layout, leave it to the board code or
> devicetree to decide if the jz4725b-specific layout should be used
> or not.
>
> v3: - Revert the change in v2, as the previous behaviour was correct.
> - Also add support for the hardware BCH of the JZ4725B in this
> patch.
>
> v4: - Add MODULE_* macros
> - Add tweaks suggested by upstream feedback
>
> drivers/mtd/nand/raw/ingenic/Kconfig | 10 +
> drivers/mtd/nand/raw/ingenic/Makefile | 1 +
> drivers/mtd/nand/raw/ingenic/ingenic_nand.c | 48 ++++-
> drivers/mtd/nand/raw/ingenic/jz4725b_bch.c | 292 ++++++++++++++++++++++++++++
> 4 files changed, 350 insertions(+), 1 deletion(-)
> create mode 100644 drivers/mtd/nand/raw/ingenic/jz4725b_bch.c
>
[...]
> +static int jz4725b_calculate(struct ingenic_ecc *bch,
> + struct ingenic_ecc_params *params,
> + const u8 *buf, u8 *ecc_code)
> +{
> + int ret;
> +
> + mutex_lock(&bch->lock);
> + ret = jz4725b_bch_init(bch, params, true);
I really don't like this bch_init name. A BCH initialization is what is
supposed to be done only once (probably at boot time), can you find a
better name or a better organization of the correct/calculate path?
> + if (ret) {
> + dev_err(bch->dev, "Unable to init BCH with given parameters\n");
> + goto out_disable;
> + }
> +
> + jz4725b_bch_write_data(bch, buf, params->size);
> +
> + ret = jz4725b_bch_wait_complete(bch, BCH_BHINT_ENCF, NULL);
> + if (ret) {
> + dev_err(bch->dev, "timed out while calculating ECC\n");
> + goto out_disable;
> + }
> +
> + jz4725b_bch_read_parity(bch, ecc_code, params->bytes);
> +
> +out_disable:
> + jz4725b_bch_disable(bch);
> + mutex_unlock(&bch->lock);
> +
> + return ret;
> +}
> +
[...]
Thanks,
Miquèl
Powered by blists - more mailing lists