lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  PHC 
Open Source and information security mailing list archives
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:   Fri, 8 Mar 2019 10:28:12 +0100
From:   Daniel Lezcano <>
To:     Andy Tang <>, Shawn Guo <>
Cc:     Leo Li <>,
        "" <>,
        "" <>,
        "" <>,
        "" <>,
        "" <>,
        "" <>,
        "" <>
Subject: Re: [PATCH v2] arm64: dts: ls1088a: add one more thermal zone node

On 08/03/2019 03:07, Andy Tang wrote:
>> -----Original Message-----
>> From: Daniel Lezcano <>
>> Sent: 2019年3月7日 17:15
>> To: Andy Tang <>; Shawn Guo <>
>> Cc: Leo Li <>;;;
>> Subject: Re: [PATCH v2] arm64: dts: ls1088a: add one more thermal zone node
>>>>> PS: In order to keep consistency to the first thermal-zone node,
>>>>> there will be "WARNING: line over 80 characters" warnings.
>>>>>  arch/arm64/boot/dts/freescale/fsl-ls1088a.dtsi |   43
>>>> +++++++++++++++++++++--
>>>>>  1 files changed, 39 insertions(+), 4 deletions(-)
>>>>> diff --git a/arch/arm64/boot/dts/freescale/fsl-ls1088a.dtsi
>>>>> b/arch/arm64/boot/dts/freescale/fsl-ls1088a.dtsi
>>>>> index 661137f..9f52bc9 100644
>>>>> --- a/arch/arm64/boot/dts/freescale/fsl-ls1088a.dtsi
>>>>> +++ b/arch/arm64/boot/dts/freescale/fsl-ls1088a.dtsi
>>>>> @@ -129,19 +129,19 @@
>>>>>  	};
>>>>>  	thermal-zones {
>>>>> -		cpu_thermal: cpu-thermal {
>>>>> +		ccu {
>>>> Is this change really necessary?  What does 'ccu' stand for?
>>> I think so. ccu stands for core cluster unit. cpu is too general.
>>> On some platforms, there are more than one core clusters.
>>> At least we should change it to "core cluster" if short form is not appropriate.
>> If the sensor is a the cluster level, 'cluster' is enough. IMHO, no need to give a
>> description of what contains the cluster, otherwise you will end up with a
>> 'core-gpu-cluster-l2' name.
> If cluster is specific to core, we can use cluster instead. But I don't think so.
> Cluster may refer to "core cluster", "GPU cluster" etc.
> So, I think "core-cluster" is ok.
> If core was divided to several clusters, we can name it as "core-cluster1", "core-cluster2" etc.
> If GPU was divided to several clusters we can name it as "gpu-cluster1", "gpu-cluster2" etc. 

Hi Andy,

I think there is a confusion around the 'cpu' term and 'cluster'.

ARM would like to see the 'cluster' word to disappear, so whenever
possible we should avoid it.

>From the hardware side, 'CPU' is usually used to describe the physical
chip containing the cores+cache.

>From the software side, 'CPU' is usually used to describe the logical
process unit, aka a core or a hyper-thread.

As we are in the DT, so describing the hardware, the CPU refers to the
group cores+caches.

>From my POV, using 'cpu' for the group of cores and 'gpu' for the
graphic sounds ok, and so far that is what is used for the other platforms.

If you change the name, that may give the feeling there is something
special with those thermal zones.

 <> │ Open source software for ARM SoCs

Follow Linaro:  <> Facebook |
<!/linaroorg> Twitter |
<> Blog

Powered by blists - more mailing lists