lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  PHC 
Open Source and information security mailing list archives
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:   Sun, 17 Mar 2019 08:50:11 +0100
From:   Miguel Ojeda <>
To:     NeilBrown <>
Cc:     Thomas Graf <>,
        Herbert Xu <>,
        Network Development <>,
        "Paul E. McKenney" <>,
        linux-kernel <>
Subject: Re: [PATCH 3/3] rhashtable: rename rht_for_each*continue as *from.

On Thu, Mar 14, 2019 at 6:10 AM NeilBrown <> wrote:
> The pattern set by list.h is that for_each..continue()
> iterators start at the next entry after the given one,
> while for_each..from() iterators start at the given
> entry.
> The rht_for_each*continue() iterators are documented as though the
> start at the 'next' entry, but actually start at the given entry,
> and they are used expecting that behaviour.
> So fix the documentation and change the names to *from for consistency
> with list.h

Thank you for taking care of the .clang-format changes!

Acked-by: Miguel Ojeda <>


Powered by blists - more mailing lists